summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-04-20 18:15:02 +0200
committerJohannes Huber <johu@gentoo.org>2017-04-20 18:22:40 +0200
commit8f00b2bf566d896205f52099530159c97b977f68 (patch)
tree6dfeae9f7a9dc7b276cb384a7f4ad8d589de52d1 /kde-apps/kopete
parentkde5*eclass: KDE Applications 17.04.0 improvements (diff)
downloadgentoo-8f00b2bf566d896205f52099530159c97b977f68.tar.gz
gentoo-8f00b2bf566d896205f52099530159c97b977f68.tar.bz2
gentoo-8f00b2bf566d896205f52099530159c97b977f68.zip
kde-apps: Version bump KDE Applications 17.04.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/Manifest1
-rw-r--r--kde-apps/kopete/kopete-17.04.0.ebuild162
2 files changed, 163 insertions, 0 deletions
diff --git a/kde-apps/kopete/Manifest b/kde-apps/kopete/Manifest
index 60aca3428f1a..7e22c41e800d 100644
--- a/kde-apps/kopete/Manifest
+++ b/kde-apps/kopete/Manifest
@@ -1,2 +1,3 @@
DIST kopete-16.12.2.tar.xz 6339196 SHA256 2b0a73771f842998a2d39050367f89686409ac798592e5c191197acd9c5bc02d SHA512 fff8ab7e190b9f66f367c354f4ed75ba33653d7a7e4b42f577ca999a8c9c85f4cf09bb261b079b9d6e9108e3ef8ad9195305c82cfaeb8fe853c57236f4d30391 WHIRLPOOL 2d9905cd83e656723ce745c36685f34ffa75eb1d28e34e2ca83a4dc514f77a0cb6a4e5f70aeba72553880047c86c2343381cb7dcd95d23629dafe5d87b577ce5
DIST kopete-16.12.3.tar.xz 6340128 SHA256 61be9e45cb08e42a00bdc0e99f5d7ad7872299ac2e104124a3c0d939422376b6 SHA512 00327485a367e0daa69dc67bfe0e7cd12293fe57bcc22d48fe0872546b3f757dbd2e349c557ad89452951d59340f615b66a7d4155a7b29fceb3d404d0b6006b7 WHIRLPOOL 9e061459783e15751d795ef4b4d16ca387d8fcbdb745f5ded141c3a7ddbd3a52066e4c7e892d71a838db36c8ee514d17dce1e9861a57d9ad11792e7cfd440c61
+DIST kopete-17.04.0.tar.xz 6340128 SHA256 50dab3e927a992bb30a801edb1dab50526ab0f04744b558be15a17b94f2cb3f1 SHA512 5323362fed37f99cc9a45eead13b4fcf2346cddf270f73716858cf38b36043a56d73d51035e9007975e92f96df4814b0b282cdcc13107cd75e4e8d8273effa59 WHIRLPOOL 6246e2f1b47ef46965b20e361da4b8a5deb8699956369d9ec8d3408b4f7eaacd958c124f80f4f638ecf5ea3651dd1fe6b370330d31c2cb65630052e8fecb8346
diff --git a/kde-apps/kopete/kopete-17.04.0.ebuild b/kde-apps/kopete/kopete-17.04.0.ebuild
new file mode 100644
index 000000000000..be9563fab702
--- /dev/null
+++ b/kde-apps/kopete/kopete-17.04.0.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="https://kopete.kde.org https://www.kde.org/applications/internet/kopete"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug ssl v4l"
+
+# tests hang, last checked for 4.2.96
+RESTRICT+=" test"
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# cryptography: kde-apps/kdepim-common-libs:4 or kde-apps/libkleo:4
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes cryptography +highlight
++history latex +nowlistening otr +pipes +privacy +statistics +texteffect
++translator +urlpicpreview webpresence"
+
+# Available protocols
+#
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# yahoo: media-libs/jasper
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise jingle meanwhile oscar skype
+testbed winpopup +xmpp yahoo zeroconf"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+# msn: net-libs/libmsn
+# qq: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ $(add_kdeapps_dep kdepimlibs)
+ dev-libs/libpcre
+ >=dev-qt/qtgui-4.4.0:4[mng]
+ kde-frameworks/kdelibs:4[zeroconf?]
+ media-libs/phonon[qt4]
+ media-libs/qimageblitz
+ !aqua? (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ )
+ cryptography? (
+ || (
+ $(add_kdeapps_dep kdepim-common-libs)
+ $(add_kdeapps_dep libkleo '' 4.4.2016.01-r1)
+ )
+ )
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2[qt4(+)] )
+ jingle? (
+ dev-libs/expat
+ dev-libs/openssl:0
+ >=media-libs/mediastreamer-2.3.0
+ net-libs/libsrtp:=
+ net-libs/ortp:=
+ )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ app-crypt/qca:2[qt4(+)]
+ dev-libs/qjson
+ net-dns/libidn
+ sys-libs/zlib
+ )
+ yahoo? ( media-libs/jasper )
+"
+RDEPEND="${COMMONDEPEND}
+ jingle? ( media-libs/speex )
+ latex? (
+ virtual/imagemagick-tools
+ virtual/latex-base
+ )
+ ssl? ( app-crypt/qca:2[ssl] )
+ winpopup? ( net-fs/samba )
+"
+DEPEND="${COMMONDEPEND}
+ jingle? ( dev-libs/jsoncpp )
+ !aqua? ( x11-proto/scrnsaverproto )
+"
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_LiboRTP=$(usex jingle)
+ -DWITH_Mediastreamer=$(usex jingle)
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ jingle) x2=libjingle ;;
+ xmpp) x2=jabber ;;
+ zeroconf) x2=bonjour ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ mycmakeargs+=( -DWITH_Libmsn=OFF -DWITH_qq=OFF -DWITH_sms=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use ssl; then
+ if use xmpp ; then # || use irc; then
+ if ! has_version "app-crypt/qca:2[ssl]" ; then
+ elog "In order to use ssl in xmpp you'll need to"
+ elog "install app-crypt/qca package with USE=ssl."
+ fi
+ fi
+ fi
+}