summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-03-05 20:20:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-01 10:02:27 +0200
commita8850d17d0b4b533bc864b385164e20a5b4686f1 (patch)
tree663758222f5a0bd4af46fb8183fabdb14d525ed5 /kde-apps/kopete
parentkde-apps: KDE PIM 4.4.2017.04 version bump (diff)
downloadgentoo-a8850d17d0b4b533bc864b385164e20a5b4686f1.tar.gz
gentoo-a8850d17d0b4b533bc864b385164e20a5b4686f1.tar.bz2
gentoo-a8850d17d0b4b533bc864b385164e20a5b4686f1.zip
kde-apps/kopete: Fix configure w/ >=kde-apps/kdepimlibs-4.14.10_p20160611
Update gpgme++ and qgpgme references. Gentoo-bug: 611818
Diffstat (limited to 'kde-apps/kopete')
-rw-r--r--kde-apps/kopete/files/kopete-17.04.0-kde4qgpgme.patch56
-rw-r--r--kde-apps/kopete/kopete-17.04.0-r1.ebuild165
2 files changed, 221 insertions, 0 deletions
diff --git a/kde-apps/kopete/files/kopete-17.04.0-kde4qgpgme.patch b/kde-apps/kopete/files/kopete-17.04.0-kde4qgpgme.patch
new file mode 100644
index 000000000000..6589f06027ba
--- /dev/null
+++ b/kde-apps/kopete/files/kopete-17.04.0-kde4qgpgme.patch
@@ -0,0 +1,56 @@
+--- /CMakeLists.txt
++++ /CMakeLists.txt
+@@ -98,8 +98,8 @@
+ macro_optional_find_package(QJSON)
+ macro_log_feature(QJSON_FOUND "QJSON" "JSON handling library for Qt" "http://qjson.sourceforge.net/" FALSE "" "Required for the Jabber protocol")
+
+-macro_optional_find_package(QGpgme)
+-macro_log_feature(QGPGME_FOUND "QGpgme" "QGpgME library (from kdepimlibs)" "http://www.kde.org/" FALSE "" "Required for the Cryptography plugin")
++macro_optional_find_package(KDE4_QGpgme)
++macro_log_feature(KDE4_QGPGME_FOUND "KDE4_QGpgme" "KDE4_QGpgME library (from kdepimlibs)" "http://www.kde.org/" FALSE "" "Required for the Cryptography plugin")
+
+ macro_optional_find_package(Sqlite)
+ macro_log_feature(SQLITE_FOUND "Sqlite" "SQLite is a Binary-Database" "http://www.sqlite.org/" FALSE "" "Required for the Statistic plugin")
+--- /plugins/CMakeLists.txt
++++ /plugins/CMakeLists.txt
+@@ -74,6 +74,6 @@
+ if (WITH_otr AND LIBOTR_FOUND)
+ add_subdirectory ( otr )
+ endif (WITH_otr AND LIBOTR_FOUND)
+-if (WITH_cryptography AND KLEOPATRA_FOUND AND QGPGME_FOUND)
++if (WITH_cryptography AND KLEOPATRA_FOUND AND KDE4_QGPGME_FOUND)
+ add_subdirectory ( cryptography )
+-endif (WITH_cryptography AND KLEOPATRA_FOUND AND QGPGME_FOUND)
++endif (WITH_cryptography AND KLEOPATRA_FOUND AND KDE4_QGPGME_FOUND)
+--- /plugins/cryptography/CMakeLists.txt
++++ /plugins/cryptography/CMakeLists.txt
+@@ -17,7 +17,7 @@
+
+ kde4_add_plugin(kopete_cryptography ${kopete_cryptography_PART_SRCS})
+
+-target_link_libraries(kopete_cryptography ${QT_QTGUI_LIBRARY} ${KDE4_KDECORE_LIBS} kopete ${KLEOPATRA_LIBRARIES} ${KDE4_KABC_LIBS} ${QGPGME_LIBRARIES} )
++target_link_libraries(kopete_cryptography ${QT_QTGUI_LIBRARY} ${KDE4_KDECORE_LIBS} kopete ${KLEOPATRA_LIBRARIES} ${KDE4_KABC_LIBS} ${KDE4_QGPGME_LIBRARIES} )
+
+ install(TARGETS kopete_cryptography DESTINATION ${PLUGIN_INSTALL_DIR})
+
+--- /plugins/cryptography/cryptographyplugin.cpp
++++ /plugins/cryptography/cryptographyplugin.cpp
+@@ -52,12 +52,12 @@
+ #include <kleo/signjob.h>
+ #include <kleo/keylistjob.h>
+ #include <kleo/job.h>
+-#include <gpgme++/decryptionresult.h>
+-#include <gpgme++/verificationresult.h>
+-#include <gpgme++/keylistresult.h>
+-#include <gpgme++/signingresult.h>
+-#include <gpgme++/encryptionresult.h>
+-#include <gpgme++/key.h>
++#include <kde4_gpgme++/decryptionresult.h>
++#include <kde4_gpgme++/verificationresult.h>
++#include <kde4_gpgme++/keylistresult.h>
++#include <kde4_gpgme++/signingresult.h>
++#include <kde4_gpgme++/encryptionresult.h>
++#include <kde4_gpgme++/key.h>
+
+ // kabc stuff
+ #include <kabc/addressbook.h>
diff --git a/kde-apps/kopete/kopete-17.04.0-r1.ebuild b/kde-apps/kopete/kopete-17.04.0-r1.ebuild
new file mode 100644
index 000000000000..2a6b3f1f6d8a
--- /dev/null
+++ b/kde-apps/kopete/kopete-17.04.0-r1.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="https://kopete.kde.org https://www.kde.org/applications/internet/kopete"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug ssl v4l"
+
+# tests hang, last checked for 4.2.96
+RESTRICT+=" test"
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# cryptography: kde-apps/kdepim-common-libs:4 or kde-apps/libkleo:4
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes cryptography +highlight
++history latex +nowlistening otr +pipes +privacy +statistics +texteffect
++translator +urlpicpreview webpresence"
+
+# Available protocols
+#
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# oscar: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# yahoo: media-libs/jasper
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise jingle meanwhile oscar skype
+testbed winpopup +xmpp yahoo zeroconf"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+# msn: net-libs/libmsn
+# qq: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ $(add_kdeapps_dep kdepimlibs '' 4.14.10_p20160611)
+ dev-libs/libpcre
+ >=dev-qt/qtgui-4.4.0:4[mng]
+ kde-frameworks/kdelibs:4[zeroconf?]
+ media-libs/phonon[qt4]
+ media-libs/qimageblitz
+ !aqua? (
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ )
+ cryptography? (
+ || (
+ $(add_kdeapps_dep kdepim-common-libs)
+ $(add_kdeapps_dep libkleo '' 4.4.2016.01-r1)
+ )
+ )
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2[qt4(+)] )
+ jingle? (
+ dev-libs/expat
+ dev-libs/openssl:0
+ >=media-libs/mediastreamer-2.3.0
+ net-libs/libsrtp:=
+ net-libs/ortp:=
+ )
+ meanwhile? ( net-libs/meanwhile )
+ otr? ( >=net-libs/libotr-4.0.0 )
+ statistics? ( dev-db/sqlite:3 )
+ v4l? ( media-libs/libv4l )
+ webpresence? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+ xmpp? (
+ app-crypt/qca:2[qt4(+)]
+ dev-libs/qjson
+ net-dns/libidn
+ sys-libs/zlib
+ )
+ yahoo? ( media-libs/jasper )
+"
+RDEPEND="${COMMONDEPEND}
+ !=kde-apps/kdepimlibs-4.14.11_pre20160211*
+ jingle? ( media-libs/speex )
+ latex? (
+ virtual/imagemagick-tools
+ virtual/latex-base
+ )
+ ssl? ( app-crypt/qca:2[ssl] )
+ winpopup? ( net-fs/samba )
+"
+DEPEND="${COMMONDEPEND}
+ jingle? ( dev-libs/jsoncpp )
+ !aqua? ( x11-proto/scrnsaverproto )
+"
+
+PATCHES=( "${FILESDIR}/${P}-kde4qgpgme.patch" )
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ local mycmakeargs=(
+ -DWITH_LiboRTP=$(usex jingle)
+ -DWITH_Mediastreamer=$(usex jingle)
+ -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ jingle) x2=libjingle ;;
+ xmpp) x2=jabber ;;
+ zeroconf) x2=bonjour ;;
+ *) x2=${x/+/} ;;
+ esac
+ mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )
+ done
+
+ mycmakeargs+=( -DWITH_Libmsn=OFF -DWITH_qq=OFF -DWITH_sms=OFF )
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( -DWITH_${x/+/}=$(usex ${x/+/}) )
+ done
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use ssl; then
+ if use xmpp ; then # || use irc; then
+ if ! has_version "app-crypt/qca:2[ssl]" ; then
+ elog "In order to use ssl in xmpp you'll need to"
+ elog "install app-crypt/qca package with USE=ssl."
+ fi
+ fi
+ fi
+}