summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/kstars
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/kstars')
-rw-r--r--kde-apps/kstars/Manifest1
-rw-r--r--kde-apps/kstars/files/kstars-4.14.3-indilib100.patch26
-rw-r--r--kde-apps/kstars/kstars-4.14.3-r1.ebuild37
-rw-r--r--kde-apps/kstars/kstars-4.14.3.ebuild35
-rw-r--r--kde-apps/kstars/metadata.xml9
5 files changed, 108 insertions, 0 deletions
diff --git a/kde-apps/kstars/Manifest b/kde-apps/kstars/Manifest
new file mode 100644
index 000000000000..e26ec233ba61
--- /dev/null
+++ b/kde-apps/kstars/Manifest
@@ -0,0 +1 @@
+DIST kstars-4.14.3.tar.xz 12374500 SHA256 771c46e8985724d7f5be74f4813bfba0a62cbb48e1c8d0cd27394a6f0ef15bde SHA512 c843506ae0d85e03b9ac3b11be73f35b66f9fc64adddf7a4643cb397fc59628920254aa056d7bf968b54893ce035d40d0c17a7d0fc576d3dae5799fd0f16ec3e WHIRLPOOL 752f69a01d8344aed4c276bb4920c6791bf223aac8c8adfb0ab9833425b625793978316033a1cfba5ae43d221896a9c93a4e5b43f19a42730cbe7fc282318a0a
diff --git a/kde-apps/kstars/files/kstars-4.14.3-indilib100.patch b/kde-apps/kstars/files/kstars-4.14.3-indilib100.patch
new file mode 100644
index 000000000000..9b26cec4f0ac
--- /dev/null
+++ b/kde-apps/kstars/files/kstars-4.14.3-indilib100.patch
@@ -0,0 +1,26 @@
+From 97c3d53af2998420f7646b3a482417d00c291ec8 Mon Sep 17 00:00:00 2001
+From: Jasem Mutlaq <mutlaqja@ikarustech.com>
+Date: Mon, 1 Dec 2014 00:50:27 +0300
+Subject: [PATCH] use std::string from libindi
+
+---
+ kstars/indi/indidevice.cpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/kstars/indi/indidevice.cpp b/kstars/indi/indidevice.cpp
+index f52decc..2a05ca6 100644
+--- a/kstars/indi/indidevice.cpp
++++ b/kstars/indi/indidevice.cpp
+@@ -268,7 +268,8 @@ void INDI_D::updateMessageLog(INDI::BaseDevice *idv, int messageID)
+ return;
+
+ msgST_w->ensureCursorVisible();
+- msgST_w->insertPlainText(dv->messageQueue(messageID) + QString("\n"));
++ msgST_w->insertPlainText(QString::fromStdString(dv->messageQueue(messageID)));
++ msgST_w->insertPlainText("\n");
+ QTextCursor c = msgST_w->textCursor();
+ c.movePosition(QTextCursor::Start);
+ msgST_w->setTextCursor(c);
+--
+2.0.5
+
diff --git a/kde-apps/kstars/kstars-4.14.3-r1.ebuild b/kde-apps/kstars/kstars-4.14.3-r1.ebuild
new file mode 100644
index 000000000000..6dfe75b9c6b5
--- /dev/null
+++ b/kde-apps/kstars/kstars-4.14.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit flag-o-matic kde4-base
+
+DESCRIPTION="KDE Desktop Planetarium"
+HOMEPAGE="http://www.kde.org/applications/education/kstars http://edu.kde.org/kstars"
+KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug fits indi"
+
+REQUIRED_USE="indi? ( fits )"
+
+DEPEND="
+ dev-cpp/eigen:3
+ $(add_kdeapps_dep libkdeedu)
+ fits? ( >=sci-libs/cfitsio-0.390 )
+ indi? ( >=sci-libs/indilib-0.9.8 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-indilib100.patch" )
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ local mycmakeargs=(
+ $(cmake-utils_use_with fits CFitsio)
+ $(cmake-utils_use_with indi)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/kde-apps/kstars/kstars-4.14.3.ebuild b/kde-apps/kstars/kstars-4.14.3.ebuild
new file mode 100644
index 000000000000..ccd85a073abe
--- /dev/null
+++ b/kde-apps/kstars/kstars-4.14.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit flag-o-matic kde4-base
+
+DESCRIPTION="KDE Desktop Planetarium"
+HOMEPAGE="http://www.kde.org/applications/education/kstars http://edu.kde.org/kstars"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug fits indi"
+
+REQUIRED_USE="indi? ( fits )"
+
+DEPEND="
+ dev-cpp/eigen:3
+ $(add_kdeapps_dep libkdeedu)
+ fits? ( >=sci-libs/cfitsio-0.390 )
+ indi? ( >=sci-libs/indilib-0.9.8 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ local mycmakeargs=(
+ $(cmake-utils_use_with fits CFitsio)
+ $(cmake-utils_use_with indi)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/kde-apps/kstars/metadata.xml b/kde-apps/kstars/metadata.xml
new file mode 100644
index 000000000000..79595fbd91d8
--- /dev/null
+++ b/kde-apps/kstars/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="fits">Enable support for the FITS image format through cfitsio</flag>
+ <flag name="indi">Enable support for Astronomical control library using libindi</flag>
+ </use>
+ <herd>kde</herd>
+</pkgmetadata>