summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-03-17 01:02:23 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-19 01:40:03 +1100
commit0faa533194f922db80dcf86edcf71679200ae1bf (patch)
tree9e845b2bae6c5b79b2baf00aea17c64a1dc0f361 /kde-apps/ksudoku/ksudoku-15.12.3.ebuild
parentkde-apps: Drop 15.12.1 (diff)
downloadgentoo-0faa533194f922db80dcf86edcf71679200ae1bf.tar.gz
gentoo-0faa533194f922db80dcf86edcf71679200ae1bf.tar.bz2
gentoo-0faa533194f922db80dcf86edcf71679200ae1bf.zip
kde-apps: Add kdegames-meta-15.12.3 from kde overlay
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-apps/ksudoku/ksudoku-15.12.3.ebuild')
-rw-r--r--kde-apps/ksudoku/ksudoku-15.12.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-apps/ksudoku/ksudoku-15.12.3.ebuild b/kde-apps/ksudoku/ksudoku-15.12.3.ebuild
new file mode 100644
index 000000000000..ad3395be5d13
--- /dev/null
+++ b/kde-apps/ksudoku/ksudoku-15.12.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+OPENGL_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE Sudoku"
+HOMEPAGE="
+ https://www.kde.org/applications/games/ksudoku/
+ https://games.kde.org/game.php?game=ksudoku
+"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdeapps_dep libkdegames)
+ opengl? ( virtual/glu )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+ kde4-base_src_configure
+}