summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-12 19:24:29 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-12 19:24:41 +0100
commit2066cf7b5a1da5ded50affbdc96467b431140f3e (patch)
treeeec619c4a351b2aa2376ea6f0d543086f9b9c747 /kde-apps/ksudoku/ksudoku-16.12.1.ebuild
parentdev-python/bandit: bup (diff)
downloadgentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.tar.gz
gentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.tar.bz2
gentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.zip
kde-apps: Version bump KDE Applications 16.12.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/ksudoku/ksudoku-16.12.1.ebuild')
-rw-r--r--kde-apps/ksudoku/ksudoku-16.12.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-apps/ksudoku/ksudoku-16.12.1.ebuild b/kde-apps/ksudoku/ksudoku-16.12.1.ebuild
new file mode 100644
index 000000000000..6d9b1db391b2
--- /dev/null
+++ b/kde-apps/ksudoku/ksudoku-16.12.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+OPENGL_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Sudoku by KDE"
+HOMEPAGE="
+ https://www.kde.org/applications/games/ksudoku/
+ https://games.kde.org/game.php?game=ksudoku
+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdeapps_dep libkdegames)
+ opengl? ( virtual/glu )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_OpenGL=$(usex opengl)
+ )
+ kde4-base_src_configure
+}