summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:21:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:58:09 +0200
commitc1063afea17a29bb75dbbbf0121fa5c8ad948574 (patch)
treec62ccf9ec787742c39c2afd14ac1198894802629 /kde-apps/ksystemlog
parentmedia-libs/libqaccessibilityclient: New package (diff)
downloadgentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.gz
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.bz2
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.zip
kde-apps: Add KDE Applications 17.08.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-apps/ksystemlog')
-rw-r--r--kde-apps/ksystemlog/Manifest1
-rw-r--r--kde-apps/ksystemlog/ksystemlog-17.08.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/kde-apps/ksystemlog/Manifest b/kde-apps/ksystemlog/Manifest
index dcc603f4edc7..ff71d672846a 100644
--- a/kde-apps/ksystemlog/Manifest
+++ b/kde-apps/ksystemlog/Manifest
@@ -1 +1,2 @@
DIST ksystemlog-17.04.3.tar.xz 1782104 SHA256 f12471b5fa940aca4aa645a732b89d260b2d9512e6468eaae8a010f10467e701 SHA512 20a27120837289255bee94afe81f03e12692b89a9d3fbae0e9e0adc1062c71ac392acae2b70a4bb74448d84cd202065fd1718de593fa40f0d06a5596e6af2d2d WHIRLPOOL e6ad4bd4afde134b033dc45c1f354f358b73daffae7ce0072bee349b67a662cbbd1b2080b97d9b66780b65dae1a34d98a48e84915ef9f90d6141430466e08fa1
+DIST ksystemlog-17.08.0.tar.xz 1782276 SHA256 7856be30e1c0f665cc3ba4cddc7002bdb4a4b15f6d55edf340016114f5418358 SHA512 041dc49f5d2e6431af2d4b6852aa05e68876a25b925a4daf20cd4b3a36a4020be4c4bf343e65e1402c1b89776d6fe9ed28c4ca5eecdaa45e2f26a22bd3ed360d WHIRLPOOL d1417211e0b0e2f23eecfd639f21fd4f27e67567bbdef0a2f14bce180ba80fdca0ddd0e8038aff40ceeabd46b3f4020e778e755ccdd52d035a5a3dcfddd0971b
diff --git a/kde-apps/ksystemlog/ksystemlog-17.08.0.ebuild b/kde-apps/ksystemlog/ksystemlog-17.08.0.ebuild
new file mode 100644
index 000000000000..7caf52a9ff05
--- /dev/null
+++ b/kde-apps/ksystemlog/ksystemlog-17.08.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="System log viewer by KDE"
+HOMEPAGE="https://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+# bug 378101
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package systemd Journald)
+ )
+ kde5_src_configure
+}