summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 15:29:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 15:30:09 +0200
commitd9397ab8d48feb4b1360be614da35fa2faae44d9 (patch)
treecc33135aeeb6bb0faab58e8efc34329c14dff2b0 /kde-apps/ksystemlog
parentdev-libs/libnl: Add USE='debug threads'. (diff)
downloadgentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.tar.gz
gentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.tar.bz2
gentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.zip
kde-apps: Add KDE Applications 18.04.1
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'kde-apps/ksystemlog')
-rw-r--r--kde-apps/ksystemlog/Manifest1
-rw-r--r--kde-apps/ksystemlog/ksystemlog-18.04.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/kde-apps/ksystemlog/Manifest b/kde-apps/ksystemlog/Manifest
index 79223e94380e..4020a841f778 100644
--- a/kde-apps/ksystemlog/Manifest
+++ b/kde-apps/ksystemlog/Manifest
@@ -1,2 +1,3 @@
DIST ksystemlog-17.12.3.tar.xz 1782044 BLAKE2B 0679e1f79edf65dc99958932d1e60cf4e5979d02786a97b0f5181a819b289ceb3dd219b4678dd84537df4fabec0560a6cf112fd55adb1155da2060b826acdd39 SHA512 b9f1a56a4ec0c26cae5556f3454d69fb7f186762affe95008ee4403071a42d1c76cc2b8451fdd19b3d0302fb0f2b1e7c8e04f84b0efae6fda3ceac90d83d9b61
DIST ksystemlog-18.04.0.tar.xz 1781444 BLAKE2B da505697b4dfb1924d30b94504f76b78a1048bfbeeffc48b26a9e6017fcda729c4b809f14ff35aa50292c3127b15d38f9998593aabcd28d929152e9f23de11ff SHA512 b23a748f3e1fb46a56f469cd9fd3fffa21c5614af1a96cab142d247545dc00f2c17c50495086c7e5694a7259e8ce6944f25e580a743143089b1332f8e1378e56
+DIST ksystemlog-18.04.1.tar.xz 1784856 BLAKE2B 91ae07e9b968f695efcd3e5ec8a3b17286eec3a786d55423e2d4db7a486f9ce41ae817eb16204e792ac39f4e0a4a308fd22bc2f51af66852d649bd526667dd34 SHA512 714cb96ccd5201c4e6716bf8520bc315cf17fcb3485568cb50578fc011c42c04d63704272209d959d70dc00e2457b46aefd2d011b0ddf8cd6f4dc1db00fad698
diff --git a/kde-apps/ksystemlog/ksystemlog-18.04.1.ebuild b/kde-apps/ksystemlog/ksystemlog-18.04.1.ebuild
new file mode 100644
index 000000000000..613a2eccdf4d
--- /dev/null
+++ b/kde-apps/ksystemlog/ksystemlog-18.04.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="System log viewer by KDE"
+HOMEPAGE="https://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+# bug 378101
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package systemd Journald)
+ )
+ kde5_src_configure
+}