summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-03-09 20:09:53 +0100
committerJohannes Huber <johu@gentoo.org>2017-03-09 20:26:05 +0100
commit40cce1797befe332a79f52bba80e3d144297ceff (patch)
treea466705e4322739fd5dc6f2501eb401b5fe02385 /kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-16.12.3.ebuild
parentdev-db/percona-server: Security cleanup (bug #612150) (diff)
downloadgentoo-40cce1797befe332a79f52bba80e3d144297ceff.tar.gz
gentoo-40cce1797befe332a79f52bba80e3d144297ceff.tar.bz2
gentoo-40cce1797befe332a79f52bba80e3d144297ceff.zip
kde-apps: Version bump KDE Applications 16.12.3
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-16.12.3.ebuild')
-rw-r--r--kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-16.12.3.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-16.12.3.ebuild b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-16.12.3.ebuild
new file mode 100644
index 000000000000..a67ec19116e1
--- /dev/null
+++ b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-16.12.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy account management kcm"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="experimental"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep kaccounts-integration)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+ net-libs/signond
+ net-libs/telepathy-qt[qt5]
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kio)
+ net-libs/libaccounts-glib
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdeapps_dep kaccounts-providers)
+ net-im/telepathy-connection-managers
+ !kde-apps/ktp-accounts-kcm:4
+"
+
+src_prepare() {
+ if use experimental; then
+ mv "${S}"/data/kaccounts/disabled/*.in "${S}"/data/kaccounts/ || die "couldn't enable experimental services"
+ fi
+ kde5_src_prepare
+}
+
+pkg_postinst() {
+ if use experimental; then
+ ewarn "Experimental providers are enabled."
+ ewarn "Most of them aren't integrated nicely and may require additional steps for account creation."
+ ewarn "Use at your own risk!"
+ fi
+}