summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-12 16:10:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-12 16:18:26 +0200
commita6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4 (patch)
tree4d3ec8ddaa83500e5b7b78a9fdbb5d4fd20540d5 /kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.08.2.ebuild
parentkde-frameworks/kdelibs: 4.14.37 version bump (diff)
downloadgentoo-a6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4.tar.gz
gentoo-a6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4.tar.bz2
gentoo-a6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4.zip
kde-apps: Add KDE Applications 17.08.2
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.08.2.ebuild')
-rw-r--r--kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.08.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.08.2.ebuild b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.08.2.ebuild
new file mode 100644
index 000000000000..c3e1afbf75fd
--- /dev/null
+++ b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.08.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy account management kcm"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="experimental"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep kaccounts-integration)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+ net-libs/signond
+ net-libs/telepathy-qt[qt5(+)]
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kio)
+ net-libs/libaccounts-glib
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdeapps_dep kaccounts-providers)
+ net-im/telepathy-connection-managers
+"
+
+src_prepare() {
+ if use experimental; then
+ mv "${S}"/data/kaccounts/disabled/*.in "${S}"/data/kaccounts/ || die "couldn't enable experimental services"
+ fi
+ kde5_src_prepare
+}
+
+pkg_postinst() {
+ if use experimental; then
+ ewarn "Experimental providers are enabled."
+ ewarn "Most of them aren't integrated nicely and may require additional steps for account creation."
+ ewarn "Use at your own risk!"
+ fi
+}