summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:14:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:25:03 +0100
commit576fc933c81aa6e526d87290af95e8e898e70ecb (patch)
tree73f9a202bcb454043dbb6b731d9b56ed4c5f49eb /kde-apps/ktp-accounts-kcm
parentdev-haskell/stack-bin: bump up to 1.6.1 (diff)
downloadgentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.gz
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.bz2
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.zip
kde-apps: Add KDE Applications 17.12.0
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'kde-apps/ktp-accounts-kcm')
-rw-r--r--kde-apps/ktp-accounts-kcm/Manifest1
-rw-r--r--kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.12.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/kde-apps/ktp-accounts-kcm/Manifest b/kde-apps/ktp-accounts-kcm/Manifest
index 95714b4700c8..f6b009c0c37a 100644
--- a/kde-apps/ktp-accounts-kcm/Manifest
+++ b/kde-apps/ktp-accounts-kcm/Manifest
@@ -1 +1,2 @@
DIST ktp-accounts-kcm-17.08.3.tar.xz 262952 BLAKE2B fe6230d7cb739c26194a2ef05493aed1bc4ed7c298b1fd143701fc564619e2b872162eb30d827e7e795ef20c15f1253b8a177e8efc6c5c144b53c12487c5cfa9 SHA512 a621cc83c7dd3827af55ab5abc486ce34af9281e194fea80489acb4b2c4060f1686433b974c56e333368b79284421acf556f28e0f4035d6fc1ca1612bc155454
+DIST ktp-accounts-kcm-17.12.0.tar.xz 262908 BLAKE2B 860a6ac4f6676b6fbee3fe0468740bd825004abc9401d8584446a528e17efd1f3f798f0a286814b84efb18e714543fba42daa03c3843a57a7c2fc12cbcf3d391 SHA512 680733b2a747405f87bb533066c80e75ccfbed9fe1fec3a1f619a3db4c7663f72c95499d8a784532078529ca6f8c6177f3521b01df922e0e959482faa3bf0297
diff --git a/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.12.0.ebuild b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.12.0.ebuild
new file mode 100644
index 000000000000..c3e1afbf75fd
--- /dev/null
+++ b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-17.12.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy account management kcm"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="experimental"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep kaccounts-integration)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+ net-libs/signond
+ net-libs/telepathy-qt[qt5(+)]
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kio)
+ net-libs/libaccounts-glib
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdeapps_dep kaccounts-providers)
+ net-im/telepathy-connection-managers
+"
+
+src_prepare() {
+ if use experimental; then
+ mv "${S}"/data/kaccounts/disabled/*.in "${S}"/data/kaccounts/ || die "couldn't enable experimental services"
+ fi
+ kde5_src_prepare
+}
+
+pkg_postinst() {
+ if use experimental; then
+ ewarn "Experimental providers are enabled."
+ ewarn "Most of them aren't integrated nicely and may require additional steps for account creation."
+ ewarn "Use at your own risk!"
+ fi
+}