summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-11 14:01:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-11 14:19:52 +0200
commit9575324283ad2babba8b22185b5255376b8c686b (patch)
tree1d5567c892d13a113f6d6e7ab923fe3a0c37ba13 /kde-apps/ktp-accounts-kcm
parentmedia-gfx/krita: 4.1.4 version bump (diff)
downloadgentoo-9575324283ad2babba8b22185b5255376b8c686b.tar.gz
gentoo-9575324283ad2babba8b22185b5255376b8c686b.tar.bz2
gentoo-9575324283ad2babba8b22185b5255376b8c686b.zip
kde-apps: Add KDE Applications 18.08.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'kde-apps/ktp-accounts-kcm')
-rw-r--r--kde-apps/ktp-accounts-kcm/Manifest1
-rw-r--r--kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-18.08.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/kde-apps/ktp-accounts-kcm/Manifest b/kde-apps/ktp-accounts-kcm/Manifest
index 1baaabbaa75a..6bac31ce9ce5 100644
--- a/kde-apps/ktp-accounts-kcm/Manifest
+++ b/kde-apps/ktp-accounts-kcm/Manifest
@@ -1,2 +1,3 @@
DIST ktp-accounts-kcm-18.04.3.tar.xz 264164 BLAKE2B 39f51d40b275b72e4ed3e38bb317fd9e3ede37c8fa1991c30b412938fb835dade8ff33c51256e3fd5cde4d325f780909f3d11d93420c21b3e20a4d1579c4dcb6 SHA512 410b9cc74abdb11287d633a7188970e7e12c21797da19e2a5595057c00e3311d916e3321475309cdad6492ae2bc6404439bc78b0e83d53702fa39dbdd7c39de7
DIST ktp-accounts-kcm-18.08.1.tar.xz 264400 BLAKE2B 67dd9a0f98219b6c4d6b604f743676d2294c88bdfc61d61c07a79242a08061eda56d22a00e9912e9c2a5fd092c4ba20e8c2841d40fec2c33aa1e4c2f898b75a2 SHA512 c9c0f8a3325e099100904797fe637325c3f098e763a7603209286f1bbfacb9f5ae9b95e6cf94cc2b154cafe29d18360ba876b576172e61ae4e32cb703e20b5ee
+DIST ktp-accounts-kcm-18.08.2.tar.xz 264216 BLAKE2B 11a07ee9b5e6daa89ebddee6caebdfb6fc0d73a254e30e390139a6e9ed371072145fded9d3b4c43a84bae64f262747d269af2b42535ed158e32d4342d0d2230e SHA512 a7b135404c2a77fc29b281aa914fb953fa92c94db7572d6430247f93d9f03e3a8c3964a6358cca881553ef1851f49165a055a6ae03239be6740d287700aa2060
diff --git a/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-18.08.2.ebuild b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-18.08.2.ebuild
new file mode 100644
index 000000000000..3aef765d210e
--- /dev/null
+++ b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-18.08.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy account management kcm"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="experimental"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep kaccounts-integration)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+ net-libs/signond
+ net-libs/telepathy-qt[qt5(+)]
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kio)
+ dev-util/intltool
+ net-libs/libaccounts-glib
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdeapps_dep kaccounts-providers)
+ net-im/telepathy-connection-managers
+"
+
+src_prepare() {
+ if use experimental; then
+ mv "${S}"/data/kaccounts/disabled/*.in "${S}"/data/kaccounts/ || die "couldn't enable experimental services"
+ fi
+ kde5_src_prepare
+}
+
+pkg_postinst() {
+ if use experimental; then
+ ewarn "Experimental providers are enabled."
+ ewarn "Most of them aren't integrated nicely and may require additional steps for account creation."
+ ewarn "Use at your own risk!"
+ fi
+}