summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-09-07 20:29:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-09-07 20:29:32 +0200
commit996987a2817587de8e6dd587fdfdf8897d383ae4 (patch)
treed607e47be660333a574a1618e0f090dd0f0ea60a /kde-apps/ktp-text-ui/ktp-text-ui-17.08.1.ebuild
parentmedia-radio/flrig: Version bump (diff)
downloadgentoo-996987a2817587de8e6dd587fdfdf8897d383ae4.tar.gz
gentoo-996987a2817587de8e6dd587fdfdf8897d383ae4.tar.bz2
gentoo-996987a2817587de8e6dd587fdfdf8897d383ae4.zip
kde-apps: Add KDE Applications 17.08.1
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-apps/ktp-text-ui/ktp-text-ui-17.08.1.ebuild')
-rw-r--r--kde-apps/ktp-text-ui/ktp-text-ui-17.08.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/kde-apps/ktp-text-ui/ktp-text-ui-17.08.1.ebuild b/kde-apps/ktp-text-ui/ktp-text-ui-17.08.1.ebuild
new file mode 100644
index 000000000000..1c1ba9ca4796
--- /dev/null
+++ b/kde-apps/ktp-text-ui/ktp-text-ui-17.08.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy text chat window"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="Apache-2.0 || ( AFL-2.1 BSD ) GPL-2+ LGPL-2.1+ MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdewebkit)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kpeople)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_kdeapps_dep ktp-common-internals otr)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ net-libs/telepathy-qt[qt5(+)]
+ speech? ( $(add_qt_dep qtspeech) )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep ktp-contact-list)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}