summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-04-07 18:55:47 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-04-07 18:55:57 +1000
commit966de36d7155559b234f7272fd84b04360158f26 (patch)
tree3762373fe9c7fbb1ae6c6c9dce098a182bbbcb57 /kde-apps/kwalletd-pam
parentprofiles/package.mask: drop exim RC mask (diff)
downloadgentoo-966de36d7155559b234f7272fd84b04360158f26.tar.gz
gentoo-966de36d7155559b234f7272fd84b04360158f26.tar.bz2
gentoo-966de36d7155559b234f7272fd84b04360158f26.zip
kde-apps/kwalletd-pam: version bump
Gentoo-bug: 579212 Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-apps/kwalletd-pam')
-rw-r--r--kde-apps/kwalletd-pam/Manifest1
-rw-r--r--kde-apps/kwalletd-pam/kwalletd-pam-5.6.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/kde-apps/kwalletd-pam/Manifest b/kde-apps/kwalletd-pam/Manifest
index 48196c770bd2..1a8b167bfd75 100644
--- a/kde-apps/kwalletd-pam/Manifest
+++ b/kde-apps/kwalletd-pam/Manifest
@@ -1 +1,2 @@
DIST kwallet-pam-5.5.5.tar.xz 16280 SHA256 19c153a0593232767b370a1310f16d13673caba13842571bb7cb01535ba89336 SHA512 7daf595c110df7277a609590bb48da8a038c8516ed3bd6a6f55cdb73df850ef6989f248e5ed7b7128abd5fda0b358b4d695043c974d49451a0037b8a3280c92a WHIRLPOOL 7601debd5eed6baf4bddf98fff424280999e95bc30000663254b391e673df7b191f112689d3914d9dfec3f0bf3142fbe88b8d30b159563be659c9cc91a65ea49
+DIST kwallet-pam-5.6.2.tar.xz 17544 SHA256 53bb18eea2e4f995d685cfcb42402c2fb7b46ff139ca6a87a0cc96475bfe2703 SHA512 ae580b2b299bd6479b49d83fce165c6e944598a4c049b0244cbb369afe88e3cdcca38d53c8df98b7fd5e1614e0000102c4bf0652c1986c4abefa46c8894fc2f0 WHIRLPOOL 1c3e779b6443f251b7a4dbc69ebb6e54071d2cabf6f291d16803f324e9ff1a91a8cc50624dcbc28e18c08feea68bd629889ef5d14a8c80e3b06a5457ee990e67
diff --git a/kde-apps/kwalletd-pam/kwalletd-pam-5.6.2.ebuild b/kde-apps/kwalletd-pam/kwalletd-pam-5.6.2.ebuild
new file mode 100644
index 000000000000..c15fe5519275
--- /dev/null
+++ b/kde-apps/kwalletd-pam/kwalletd-pam-5.6.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="kwallet-pam"
+inherit cmake-utils multilib
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+HOMEPAGE="https://www.kde.org/"
+SRC_URI="mirror://kde/stable/plasma/${PV}/${MY_PN}-${PV}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ virtual/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ -DKWALLET4=1
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ check_dm() {
+ if [[ -e "${ROOT}${2}" ]] && \
+ [[ -n $(egrep "auth\s+optional\s+pam_kwallet.so" "${ROOT}${2}") ]] && \
+ [[ -n $(egrep "session\s+optional\s+pam_kwallet.so" "${ROOT}${2}") ]]; then
+ elog " ${1} - ${2} ...GOOD"
+ else
+ ewarn " ${1} - ${2} ...BAD"
+ fi
+ }
+ elog
+ elog "This package enables auto-unlocking of kde-apps/kwalletd:4."
+ elog "List of things to make it work:"
+ elog "1. Use same password for login and kwallet"
+ elog "2. A display manager with support for PAM"
+ elog "3.a Have the following lines in the display manager's pam.d file:"
+ elog " -auth optional pam_kwallet.so kdehome=.kde4"
+ elog " -session optional pam_kwallet.so"
+ elog "3.b Checking installed DMs..."
+ has_version "x11-misc/sddm" && check_dm "SDDM" "/etc/pam.d/sddm"
+ has_version "x11-misc/lightdm" && check_dm "LightDM" "/etc/pam.d/lightdm"
+ has_version "kde-base/kdm" && check_dm "KDM" "/etc/pam.d/kde"
+ elog
+}