summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-09 20:09:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-09 20:18:28 +0100
commit0e8f2a31161f9138b1731358e9e567b244c6d3d5 (patch)
tree867a9206117086871e741c4956b66e2bdb621dc4 /kde-apps/libkcddb/libkcddb-17.08.3.ebuild
parentwww-client/qupzilla: 2.2.1 version bump (diff)
downloadgentoo-0e8f2a31161f9138b1731358e9e567b244c6d3d5.tar.gz
gentoo-0e8f2a31161f9138b1731358e9e567b244c6d3d5.tar.bz2
gentoo-0e8f2a31161f9138b1731358e9e567b244c6d3d5.zip
kde-apps: Add KDE Applications 17.08.3
Package-Manager: Portage-2.3.8, Repoman-2.3.4
Diffstat (limited to 'kde-apps/libkcddb/libkcddb-17.08.3.ebuild')
-rw-r--r--kde-apps/libkcddb/libkcddb-17.08.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/kde-apps/libkcddb/libkcddb-17.08.3.ebuild b/kde-apps/libkcddb/libkcddb-17.08.3.ebuild
new file mode 100644
index 000000000000..b8f3c30529e7
--- /dev/null
+++ b/kde-apps/libkcddb/libkcddb-17.08.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_BLOCK_SLOT4="false"
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE library for CDDB"
+LICENSE="GPL-2+ handbook? ( FDL-1.2 )"
+KEYWORDS="~amd64 ~x86"
+IUSE="musicbrainz"
+
+# tests require network access and compare static data with online data
+# bug 280996
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ musicbrainz? ( media-libs/musicbrainz:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if ! use handbook ; then
+ pushd kcmcddb > /dev/null
+ cmake_comment_add_subdirectory doc
+ popd > /dev/null
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package musicbrainz MusicBrainz5)
+ )
+
+ kde5_src_configure
+}