summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-11 14:01:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-11 14:19:52 +0200
commit9575324283ad2babba8b22185b5255376b8c686b (patch)
tree1d5567c892d13a113f6d6e7ab923fe3a0c37ba13 /kde-apps/libkcddb/libkcddb-18.08.2.ebuild
parentmedia-gfx/krita: 4.1.4 version bump (diff)
downloadgentoo-9575324283ad2babba8b22185b5255376b8c686b.tar.gz
gentoo-9575324283ad2babba8b22185b5255376b8c686b.tar.bz2
gentoo-9575324283ad2babba8b22185b5255376b8c686b.zip
kde-apps: Add KDE Applications 18.08.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'kde-apps/libkcddb/libkcddb-18.08.2.ebuild')
-rw-r--r--kde-apps/libkcddb/libkcddb-18.08.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/kde-apps/libkcddb/libkcddb-18.08.2.ebuild b/kde-apps/libkcddb/libkcddb-18.08.2.ebuild
new file mode 100644
index 000000000000..904641d3237b
--- /dev/null
+++ b/kde-apps/libkcddb/libkcddb-18.08.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_BLOCK_SLOT4="false"
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE library for CDDB"
+LICENSE="GPL-2+ handbook? ( FDL-1.2 )"
+KEYWORDS="~amd64 ~x86"
+IUSE="musicbrainz"
+
+# tests require network access and compare static data with online data
+# bug 280996
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ musicbrainz? ( media-libs/musicbrainz:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if ! use handbook ; then
+ pushd kcmcddb > /dev/null
+ cmake_comment_add_subdirectory doc
+ popd > /dev/null
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package musicbrainz MusicBrainz5)
+ )
+
+ kde5_src_configure
+}