summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 15:29:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 15:30:09 +0200
commitd9397ab8d48feb4b1360be614da35fa2faae44d9 (patch)
treecc33135aeeb6bb0faab58e8efc34329c14dff2b0 /kde-apps/libkgapi/libkgapi-18.04.1.ebuild
parentdev-libs/libnl: Add USE='debug threads'. (diff)
downloadgentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.tar.gz
gentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.tar.bz2
gentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.zip
kde-apps: Add KDE Applications 18.04.1
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'kde-apps/libkgapi/libkgapi-18.04.1.ebuild')
-rw-r--r--kde-apps/libkgapi/libkgapi-18.04.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-apps/libkgapi/libkgapi-18.04.1.ebuild b/kde-apps/libkgapi/libkgapi-18.04.1.ebuild
new file mode 100644
index 000000000000..9f3e37a77649
--- /dev/null
+++ b/kde-apps/libkgapi/libkgapi-18.04.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_BLOCK_SLOT4="false"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Library for accessing Google calendar and contact resources"
+HOMEPAGE="https://cgit.kde.org/libkgapi.git"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+"
+DEPEND="${COMMON_DEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-l10n
+"