summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-14 17:13:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 07:36:14 +0200
commite19edabff80707de8772078358c8a9ca1169ca91 (patch)
treeb15a6cde4e36de6ddebe6a9e3d015312dc40dc8d /kde-apps/libkgapi/libkgapi-19.04.3.ebuild
parentkde5-functions.eclass: Update minimum deps (diff)
downloadgentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.gz
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.bz2
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.zip
kde-apps: Add KDE Applications 19.04.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/libkgapi/libkgapi-19.04.3.ebuild')
-rw-r--r--kde-apps/libkgapi/libkgapi-19.04.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-apps/libkgapi/libkgapi-19.04.3.ebuild b/kde-apps/libkgapi/libkgapi-19.04.3.ebuild
new file mode 100644
index 000000000000..8fc489120e5c
--- /dev/null
+++ b/kde-apps/libkgapi/libkgapi-19.04.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Library for accessing Google calendar and contact resources"
+HOMEPAGE="https://cgit.kde.org/libkgapi.git"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/cyrus-sasl:2
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+ !<kde-apps/kdepim-runtime-18.07.80:5
+"