summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-11-15 20:38:29 +0100
committerJohannes Huber <johu@gentoo.org>2016-11-15 20:47:49 +0100
commite805750640ffcd5150e817e77162f388021b8c0f (patch)
tree8c53c84f54ac00f079d48833e5fbc02a3937b525 /kde-apps/libkgeomap/libkgeomap-16.08.3.ebuild
parentsys-devel/gcc: mark 4.9.4 arm64/ia64/m68k/ppc/s390/sh/sparc stable #595560 (diff)
downloadgentoo-e805750640ffcd5150e817e77162f388021b8c0f.tar.gz
gentoo-e805750640ffcd5150e817e77162f388021b8c0f.tar.bz2
gentoo-e805750640ffcd5150e817e77162f388021b8c0f.zip
kde-apps: Version bump KDE Applications 16.08.3
Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-apps/libkgeomap/libkgeomap-16.08.3.ebuild')
-rw-r--r--kde-apps/libkgeomap/libkgeomap-16.08.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-apps/libkgeomap/libkgeomap-16.08.3.ebuild b/kde-apps/libkgeomap/libkgeomap-16.08.3.ebuild
new file mode 100644
index 000000000000..8773843cf051
--- /dev/null
+++ b/kde-apps/libkgeomap/libkgeomap-16.08.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Wrapper library for world map components as marble, openstreetmap and googlemap"
+HOMEPAGE="https://www.digikam.org/"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_kdeapps_dep marble 'kde' '' '5=')
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5KExiv2=true
+ )
+
+ kde5_src_configure
+}