summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-07 20:52:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-07 21:57:13 +0200
commit223f1b86f4c9bebd01d7d22e7007ea4fe9508740 (patch)
tree92a17783bb72635a967b8c2d0f47a78af761a1c5 /kde-apps/pimcommon
parentkde-apps/pim-sieve-editor: 21.08.2 version bump (diff)
downloadgentoo-223f1b86f4c9bebd01d7d22e7007ea4fe9508740.tar.gz
gentoo-223f1b86f4c9bebd01d7d22e7007ea4fe9508740.tar.bz2
gentoo-223f1b86f4c9bebd01d7d22e7007ea4fe9508740.zip
kde-apps/pimcommon: 21.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/pimcommon')
-rw-r--r--kde-apps/pimcommon/Manifest1
-rw-r--r--kde-apps/pimcommon/pimcommon-21.08.2.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-apps/pimcommon/Manifest b/kde-apps/pimcommon/Manifest
index 0476b686df9b..c454e6ab7c4b 100644
--- a/kde-apps/pimcommon/Manifest
+++ b/kde-apps/pimcommon/Manifest
@@ -1,2 +1,3 @@
DIST pimcommon-21.04.3.tar.xz 369372 BLAKE2B 4f378ae377b664839e7e7e6bc7d00565fb7ba24371582277575c23e989fd722945f0c78f187e7fcf931a26b417380e3244bddb682a23677f032a6f8faffaaa41 SHA512 b2ff1ff7942e49676aedfbe923e3a3bfa26e170007b58d2ee07d80da466b4d701fbf0707720cdc10304c7c41381c3503781993e83f88414546e605896817b320
DIST pimcommon-21.08.1.tar.xz 368912 BLAKE2B 06d7b948b823c59d9793c1b8e98924ad6a96dd8ac33835c327dc13fd11bded0b54ceda7de08d3b631a761be62c8ebfe81370768d33ebdf3a90c278a393a06244 SHA512 93db981eaa30a90ae3f5bdfd5e73308fc4d5fd4f13a6dd9d480060e929f2551e7af54de09873a28b05c1a46b011b7db7b4566801579c725cddd79010f143c2a9
+DIST pimcommon-21.08.2.tar.xz 368772 BLAKE2B 15893e1189a43db6d1125e5405a075ce20b6ed6c681ccdbf3e6b1e6ad200e4b1067de5d991c0ccc842554698bac3e0c6afbb5b540ceaa2ce1143b544f951c930 SHA512 cc0ee05aa007d3d85ca8b94f5b00fb3832ed2f558c8382c3d455984245fc9df64389fad62d365099b2be15bf0497079dcb80c37bedc28194b1fa8930a683c204
diff --git a/kde-apps/pimcommon/pimcommon-21.08.2.ebuild b/kde-apps/pimcommon/pimcommon-21.08.2.ebuild
new file mode 100644
index 000000000000..6f3a5489c88a
--- /dev/null
+++ b/kde-apps/pimcommon/pimcommon-21.08.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.84.0
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Common PIM libraries"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-libs/libxslt
+"
+COMMON_DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/akonadi-search-${PVCUT}:5
+ >=kde-apps/kimap-${PVCUT}:5
+ >=kde-apps/kldap-${PVCUT}:5
+ >=kde-apps/kpimtextedit-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/purpose-${KFMIN}:5
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=kde-apps/kmime-${PVCUT}:5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<kde-apps/libkdepim-20.07.80:5
+"
+
+src_test() {
+ # bugs 641730, 661330
+ local myctestargs=(
+ -E "(autocorrectiontest|pimcommon-translator-translatortest)"
+ )
+
+ ecm_src_test
+}