summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-03-09 20:09:53 +0100
committerJohannes Huber <johu@gentoo.org>2017-03-09 20:26:05 +0100
commit40cce1797befe332a79f52bba80e3d144297ceff (patch)
treea466705e4322739fd5dc6f2501eb401b5fe02385 /kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-16.12.3.ebuild
parentdev-db/percona-server: Security cleanup (bug #612150) (diff)
downloadgentoo-40cce1797befe332a79f52bba80e3d144297ceff.tar.gz
gentoo-40cce1797befe332a79f52bba80e3d144297ceff.tar.bz2
gentoo-40cce1797befe332a79f52bba80e3d144297ceff.zip
kde-apps: Version bump KDE Applications 16.12.3
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-16.12.3.ebuild')
-rw-r--r--kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-16.12.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-16.12.3.ebuild b/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-16.12.3.ebuild
new file mode 100644
index 000000000000..fb78a4384e83
--- /dev/null
+++ b/kde-apps/plasma-telepathy-meta/plasma-telepathy-meta-16.12.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5-meta-pkg
+
+DESCRIPTION="Plasma Telepathy client"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="|| ( GPL-2 GPL-3 LGPL-2.1 )"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer nls"
+
+[[ ${KDE_BUILD_TYPE} = live ]] && L10N_MINIMAL=${KDE_APPS_MINIMAL}
+
+RDEPEND="
+ $(add_kdeapps_dep ktp-accounts-kcm)
+ $(add_kdeapps_dep ktp-approver)
+ $(add_kdeapps_dep ktp-auth-handler)
+ $(add_kdeapps_dep ktp-common-internals)
+ $(add_kdeapps_dep ktp-contact-list)
+ $(add_kdeapps_dep ktp-contact-runner)
+ $(add_kdeapps_dep ktp-desktop-applets)
+ $(add_kdeapps_dep ktp-filetransfer-handler)
+ $(add_kdeapps_dep ktp-kded-module)
+ $(add_kdeapps_dep ktp-send-file)
+ $(add_kdeapps_dep ktp-text-ui)
+ !kde-apps/plasma-telepathy-meta:4
+ gstreamer? ( $(add_kdeapps_dep ktp-call-ui) )
+ nls? ( $(add_kdeapps_dep kde-l10n '' ${L10N_MINIMAL}) )
+"
+
+pkg_postinst() {
+ echo
+ elog "You can configure the accounts in Plasma System Settings"
+ elog "and then add the Instant Messaging plasma applet to access the contact list."
+ echo
+}