summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-12 16:10:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-12 16:18:26 +0200
commita6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4 (patch)
tree4d3ec8ddaa83500e5b7b78a9fdbb5d4fd20540d5 /kde-apps/rocs/rocs-17.08.2.ebuild
parentkde-frameworks/kdelibs: 4.14.37 version bump (diff)
downloadgentoo-a6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4.tar.gz
gentoo-a6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4.tar.bz2
gentoo-a6d3a93f1f50f5797b4d119f529dffcaf0d3a1e4.zip
kde-apps: Add KDE Applications 17.08.2
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'kde-apps/rocs/rocs-17.08.2.ebuild')
-rw-r--r--kde-apps/rocs/rocs-17.08.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/kde-apps/rocs/rocs-17.08.2.ebuild b/kde-apps/rocs/rocs-17.08.2.ebuild
new file mode 100644
index 000000000000..d4d7dc8d7a82
--- /dev/null
+++ b/kde-apps/rocs/rocs-17.08.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Interface to work with Graph Theory"
+HOMEPAGE="https://www.kde.org/applications/education/rocs
+https://edu.kde.org/applications/mathematics/rocs"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtscript 'scripttools')
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+ dev-libs/grantlee:5
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.49
+"
+
+RESTRICT+=" test" # 1/10 tests currently fails