summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-04-09 11:50:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-04-17 12:43:00 +0200
commit08d54a13dae623d073c3199e96c5393a3102f076 (patch)
tree163ae140bf2820a036b3dd78d0fe370cf6a3e52e /kde-apps/spectacle
parentkde-frameworks/kfilemetadata: Drop slot 4 (diff)
downloadgentoo-08d54a13dae623d073c3199e96c5393a3102f076.tar.gz
gentoo-08d54a13dae623d073c3199e96c5393a3102f076.tar.bz2
gentoo-08d54a13dae623d073c3199e96c5393a3102f076.zip
kde-apps: Remove KDE Applications 16.08.3
Some exceptions with reverse-dependencies remain. Closes: https://github.com/gentoo/gentoo/pull/4433
Diffstat (limited to 'kde-apps/spectacle')
-rw-r--r--kde-apps/spectacle/Manifest1
-rw-r--r--kde-apps/spectacle/files/spectacle-16.08.2-drop-kscreen.patch175
-rw-r--r--kde-apps/spectacle/spectacle-16.08.3.ebuild53
3 files changed, 0 insertions, 229 deletions
diff --git a/kde-apps/spectacle/Manifest b/kde-apps/spectacle/Manifest
index eac4b93d71ee..f4109db404bd 100644
--- a/kde-apps/spectacle/Manifest
+++ b/kde-apps/spectacle/Manifest
@@ -1,2 +1 @@
-DIST spectacle-16.08.3.tar.xz 1000760 SHA256 8b5cfbed8850643f774278b614771df0d27fe5e9eefd28765b76556358c245d5 SHA512 7373c85c130feebdb0c3505a2d4c04a21ead25392af10d1fc7892a3799e7a950d165706e1959395418704d626da3a6660080895fa58ca1e9a2f23068096d36fa WHIRLPOOL 623cb135b1ab5be075742662f08261129803fc037fde8ccaa0f90ff6f493d521a058ed55284fb42f2eb993b103dccb9ee701dde42af0bdd5bc75a75d2c90477c
DIST spectacle-16.12.3.tar.xz 1006712 SHA256 a64fa9f748e41ad63b65039aa447faf1bcdb418da0a1f81366f1e95454388ab9 SHA512 6f27f14e28bf1cfc2e6cf7e1fd11784163c8ce6ec63bded583c9b86a549891b8de806e7874cea756ea7616d0ac650695038e85282a2bc9fe32568be19c8cbb99 WHIRLPOOL 128ca2a1b314a4e033435da1c5fa0acb4a58d983101b338f1ba9ff240626746912824df0949a20ab70bc35509b2e556561fc0905a52bccf7b5e4dd38946edbb6
diff --git a/kde-apps/spectacle/files/spectacle-16.08.2-drop-kscreen.patch b/kde-apps/spectacle/files/spectacle-16.08.2-drop-kscreen.patch
deleted file mode 100644
index cd2bb7c900de..000000000000
--- a/kde-apps/spectacle/files/spectacle-16.08.2-drop-kscreen.patch
+++ /dev/null
@@ -1,175 +0,0 @@
-From: Peter Wu <peter@lekensteyn.nl>
-Date: Sat, 08 Oct 2016 20:16:06 +0000
-Subject: Replace KScreen by QScreen for current window grab
-X-Git-Url: http://quickgit.kde.org/?p=spectacle.git&a=commitdiff&h=e4c2e564a5b91497132d9a20d8f521af405286bd
----
-Replace KScreen by QScreen for current window grab
-
-libkscreen is overkill for querying purposes, rely on QScreen to find
-the current screen under cursor.
-
-REVIEW: 129127
----
-
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -75,7 +75,6 @@
- set(XCB_COMPONENTS_ERRORS FALSE)
- if (XCB_FOUND)
- find_package(Qt5X11Extras ${QT_MIN_VERSION} REQUIRED)
-- find_package(KF5Screen ${PLASMA_MIN_VERSION} REQUIRED)
- endif()
- set(XCB_COMPONENTS_FOUND TRUE)
- if(NOT XCB_XFIXES_FOUND)
-
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -83,7 +83,6 @@
- XCB::CURSOR
- XCB::UTIL
- Qt5::X11Extras
-- KF5::Screen
- )
- endif()
-
-
---- a/src/PlatformBackends/X11ImageGrabber.cpp
-+++ b/src/PlatformBackends/X11ImageGrabber.cpp
-@@ -38,17 +38,13 @@
-
- #include <KWindowSystem>
- #include <KWindowInfo>
--#include <KScreen/Config>
--#include <KScreen/GetConfigOperation>
--#include <KScreen/Output>
-
- #include <xcb/xcb_cursor.h>
- #include <xcb/xcb_util.h>
- #include <xcb/xfixes.h>
-
- X11ImageGrabber::X11ImageGrabber(QObject *parent) :
-- ImageGrabber(parent),
-- mScreenConfigOperation(nullptr)
-+ ImageGrabber(parent)
- {
- mNativeEventFilter = new OnClickEventFilter(this);
- }
-@@ -85,7 +81,6 @@
-
- {
- xcb_button_release_event_t *ev2 = static_cast<xcb_button_release_event_t *>(message);
-- qDebug() << ev2->detail;
- if (ev2->detail == 1) {
- QMetaObject::invokeMethod(mImageGrabber, "doImageGrab", Qt::QueuedConnection);
- } else if (ev2->detail < 4) {
-@@ -349,53 +344,6 @@
- emit pixmapChanged(mPixmap);
- }
-
--void X11ImageGrabber::KScreenCurrentMonitorScreenshotHelper(KScreen::ConfigOperation *op)
--{
-- KScreen::ConfigPtr config = qobject_cast<KScreen::GetConfigOperation *>(op)->config();
--
-- if (!config) { return grabFullScreen(); }
-- if (!config->screen()) { return grabFullScreen(); }
--
-- // we'll store the cursor position first
--
-- QPoint cursorPosition = QCursor::pos();
--
-- // next, we'll get all our outputs and figure out which one has the cursor
--
-- const KScreen::OutputList outputs = config->outputs();
-- for (auto output: outputs) {
-- if (!(output->isConnected())) { continue; }
-- if (!(output->currentMode())) { continue; }
--
-- QPoint screenPosition = output->pos();
-- QSize screenSize = output->currentMode()->size();
-- QRect screenRect = QRect(screenPosition, screenSize);
--
-- if (!(screenRect.contains(cursorPosition))) {
-- continue;
-- }
--
-- // bingo, we've found an output that contains the cursor. Now
-- // to take a shot
--
-- mPixmap = getWindowPixmap(QX11Info::appRootWindow(), mCapturePointer);
-- mPixmap = mPixmap.copy(screenPosition.x(), screenPosition.y(), screenSize.width(), screenSize.height());
-- emit pixmapChanged(mPixmap);
--
-- mScreenConfigOperation->disconnect();
-- mScreenConfigOperation->deleteLater();
-- mScreenConfigOperation = nullptr;
--
-- return;
-- }
--
-- mScreenConfigOperation->disconnect();
-- mScreenConfigOperation->deleteLater();
-- mScreenConfigOperation = nullptr;
--
-- return grabFullScreen();
--}
--
- void X11ImageGrabber::rectangleSelectionCancelled()
- {
- QObject *sender = QObject::sender();
-@@ -621,9 +569,20 @@
-
- void X11ImageGrabber::grabCurrentScreen()
- {
-- mScreenConfigOperation = new KScreen::GetConfigOperation;
-- connect(mScreenConfigOperation, &KScreen::GetConfigOperation::finished,
-- this, &X11ImageGrabber::KScreenCurrentMonitorScreenshotHelper);
-+ QPoint cursorPosition = QCursor::pos();
-+ for (auto screen : QGuiApplication::screens()) {
-+ const QRect screenRect = screen->geometry();
-+ if (!screenRect.contains(cursorPosition)) {
-+ continue;
-+ }
-+
-+ mPixmap = getWindowPixmap(QX11Info::appRootWindow(), mCapturePointer).copy(screenRect);
-+ emit pixmapChanged(mPixmap);
-+ return;
-+ }
-+
-+ // No screen found with our cursor, fallback to capturing full screen
-+ grabFullScreen();
- }
-
- void X11ImageGrabber::grabRectangularRegion()
-
---- a/src/PlatformBackends/X11ImageGrabber.h
-+++ b/src/PlatformBackends/X11ImageGrabber.h
-@@ -28,11 +28,6 @@
- #include "ImageGrabber.h"
-
- class X11ImageGrabber;
--namespace KScreen
--{
-- class GetConfigOperation;
-- class ConfigOperation;
--}
-
- class OnClickEventFilter : public QAbstractNativeEventFilter
- {
-@@ -70,7 +65,6 @@
- private slots:
-
- void KWinDBusScreenshotHelper(quint64 window);
-- void KScreenCurrentMonitorScreenshotHelper(KScreen::ConfigOperation *op);
- void rectangleSelectionConfirmed(const QPixmap &pixmap, const QRect &region);
- void rectangleSelectionCancelled();
-
-@@ -90,7 +84,6 @@
- QPixmap convertFromNative(xcb_image_t *xcbImage);
-
- OnClickEventFilter *mNativeEventFilter;
-- KScreen::GetConfigOperation *mScreenConfigOperation;
- };
-
- template <typename T> using CScopedPointer = QScopedPointer<T, QScopedPointerPodDeleter>;
-
diff --git a/kde-apps/spectacle/spectacle-16.08.3.ebuild b/kde-apps/spectacle/spectacle-16.08.3.ebuild
deleted file mode 100644
index 4ed17055441b..000000000000
--- a/kde-apps/spectacle/spectacle-16.08.3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_HANDBOOK="forceoptional"
-inherit kde5
-
-DESCRIPTION="Screenshot capture utility"
-LICENSE="LGPL-2+ handbook? ( FDL-1.3 ) kipi? ( GPL-2+ )"
-KEYWORDS="amd64 x86"
-IUSE="kipi share"
-
-DEPEND="
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kdbusaddons)
- $(add_frameworks_dep kdeclarative)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep knotifications)
- $(add_frameworks_dep kservice)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kwindowsystem)
- $(add_frameworks_dep kxmlgui)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtdeclarative)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtprintsupport)
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtx11extras)
- x11-libs/libxcb
- x11-libs/xcb-util
- x11-libs/xcb-util-cursor
- x11-libs/xcb-util-image
- kipi? ( $(add_kdeapps_dep libkipi '' '' '5=') )
- share? ( dev-libs/purpose:5 )
-"
-RDEPEND="${DEPEND}
- kipi? ( media-plugins/kipi-plugins:5 )
- !kde-apps/ksnapshot
-"
-
-PATCHES=( "${FILESDIR}/${PN}-16.08.2-drop-kscreen.patch" )
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_find_package kipi KF5Kipi)
- $(cmake-utils_use_find_package share KDEExperimentalPurpose)
- )
- kde5_src_configure
-}