summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2015-11-22 20:53:21 +0100
committerMichael Palimaka <kensington@gentoo.org>2015-12-06 20:45:42 +1100
commitc2f6950ca5c57264ca8a5faff62c204fd035bb51 (patch)
treeccc74831274f1919586c5a951db941c451456d69 /kde-apps/superkaramba/superkaramba-15.08.3.ebuild
parentkde-apps/kwalletmanager: Resurrect 15.04.3 for USE=minimal and fixes (diff)
downloadgentoo-c2f6950ca5c57264ca8a5faff62c204fd035bb51.tar.gz
gentoo-c2f6950ca5c57264ca8a5faff62c204fd035bb51.tar.bz2
gentoo-c2f6950ca5c57264ca8a5faff62c204fd035bb51.zip
kde-apps: Move 15.08.3 kdeutils from overlay
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'kde-apps/superkaramba/superkaramba-15.08.3.ebuild')
-rw-r--r--kde-apps/superkaramba/superkaramba-15.08.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/superkaramba/superkaramba-15.08.3.ebuild b/kde-apps/superkaramba/superkaramba-15.08.3.ebuild
new file mode 100644
index 000000000000..56aebb2b42d0
--- /dev/null
+++ b/kde-apps/superkaramba/superkaramba-15.08.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop"
+HOMEPAGE="https://www.kde.org/applications/utilities/superkaramba
+https://utils.kde.org/projects/superkaramba"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ media-libs/qimageblitz
+ x11-libs/libX11
+ x11-libs/libXrender
+ python? (
+ ${PYTHON_DEPS}
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}")
+ )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython "${PYTHON_USEDEP}") )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ kde4-base_src_configure
+}