summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-03-09 20:09:53 +0100
committerJohannes Huber <johu@gentoo.org>2017-03-09 20:26:05 +0100
commit40cce1797befe332a79f52bba80e3d144297ceff (patch)
treea466705e4322739fd5dc6f2501eb401b5fe02385 /kde-apps/thumbnailers/thumbnailers-16.12.3.ebuild
parentdev-db/percona-server: Security cleanup (bug #612150) (diff)
downloadgentoo-40cce1797befe332a79f52bba80e3d144297ceff.tar.gz
gentoo-40cce1797befe332a79f52bba80e3d144297ceff.tar.bz2
gentoo-40cce1797befe332a79f52bba80e3d144297ceff.zip
kde-apps: Version bump KDE Applications 16.12.3
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'kde-apps/thumbnailers/thumbnailers-16.12.3.ebuild')
-rw-r--r--kde-apps/thumbnailers/thumbnailers-16.12.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-apps/thumbnailers/thumbnailers-16.12.3.ebuild b/kde-apps/thumbnailers/thumbnailers-16.12.3.ebuild
new file mode 100644
index 000000000000..4bad5f5b11de
--- /dev/null
+++ b/kde-apps/thumbnailers/thumbnailers-16.12.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_BLOCK_SLOT4=false
+KMNAME="kdegraphics-thumbnailers"
+inherit kde5
+
+DESCRIPTION="Thumbnail generators for PDF/PS and RAW files"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="raw"
+
+DEPEND="
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtgui)
+ raw? (
+ $(add_kdeapps_dep libkdcraw)
+ $(add_kdeapps_dep libkexiv2)
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package raw KF5KExiv2)
+ $(cmake-utils_use_find_package raw KF5KDcraw)
+ )
+
+ kde5_src_configure
+}