summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:14:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:25:03 +0100
commit576fc933c81aa6e526d87290af95e8e898e70ecb (patch)
tree73f9a202bcb454043dbb6b731d9b56ed4c5f49eb /kde-apps/thumbnailers
parentdev-haskell/stack-bin: bump up to 1.6.1 (diff)
downloadgentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.gz
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.bz2
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.zip
kde-apps: Add KDE Applications 17.12.0
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'kde-apps/thumbnailers')
-rw-r--r--kde-apps/thumbnailers/Manifest1
-rw-r--r--kde-apps/thumbnailers/thumbnailers-17.12.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-apps/thumbnailers/Manifest b/kde-apps/thumbnailers/Manifest
index 76c52d2d0744..875f829f5da7 100644
--- a/kde-apps/thumbnailers/Manifest
+++ b/kde-apps/thumbnailers/Manifest
@@ -1 +1,2 @@
DIST kdegraphics-thumbnailers-17.08.3.tar.xz 41488 BLAKE2B 415204552ee63ca69d656d36b30daceaa53519c72cc923eede2dc77be12008d8338198d46a3a2da15e02790c72890321878e194c597daf8194a58229647f9b2f SHA512 25c533cfbf0e515fb8167143c724e877e4ed7a2100a1c0625cd53b10969a9127ae0b1f9e1a42abd076258525737a3862e7cc11bc31401551d9cdc5473c188485
+DIST kdegraphics-thumbnailers-17.12.0.tar.xz 41496 BLAKE2B c8a459b746c8e399974ad01c59b102b6f342661901f15534667f63de1f66043c23dbe000fdf68d14b6477c51676895d87a62295a347b5234f80402015f7c35c9 SHA512 e8cef7468dbdbe64299f0c9fa41e6a8d1c67ac6540b683c7c62709d0cbbf4ab93307696de4ccbaa1df7821bca98f380e686cdd340b2bda7f2c8efc9a10c9475b
diff --git a/kde-apps/thumbnailers/thumbnailers-17.12.0.ebuild b/kde-apps/thumbnailers/thumbnailers-17.12.0.ebuild
new file mode 100644
index 000000000000..4bad5f5b11de
--- /dev/null
+++ b/kde-apps/thumbnailers/thumbnailers-17.12.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_BLOCK_SLOT4=false
+KMNAME="kdegraphics-thumbnailers"
+inherit kde5
+
+DESCRIPTION="Thumbnail generators for PDF/PS and RAW files"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="raw"
+
+DEPEND="
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtgui)
+ raw? (
+ $(add_kdeapps_dep libkdcraw)
+ $(add_kdeapps_dep libkexiv2)
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package raw KF5KExiv2)
+ $(cmake-utils_use_find_package raw KF5KDcraw)
+ )
+
+ kde5_src_configure
+}