summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 22:23:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 22:51:58 +0200
commitdcde5a9e922e38fd9c51826e421bfa169353f3cc (patch)
tree00f45e3617a1728f32c24a9f37a1f5d313f72d30 /kde-apps/yakuake/yakuake-3.0.5-r1.ebuild
parentmedia-plugins/kipi-plugins: pkgmove to kde-apps/kipi-plugins (diff)
downloadgentoo-dcde5a9e922e38fd9c51826e421bfa169353f3cc.tar.gz
gentoo-dcde5a9e922e38fd9c51826e421bfa169353f3cc.tar.bz2
gentoo-dcde5a9e922e38fd9c51826e421bfa169353f3cc.zip
kde-misc/yakuake: pkgmove to kde-apps/yakuake
Part of KDE Applications starting with 19.08 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/yakuake/yakuake-3.0.5-r1.ebuild')
-rw-r--r--kde-apps/yakuake/yakuake-3.0.5-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/kde-apps/yakuake/yakuake-3.0.5-r1.ebuild b/kde-apps/yakuake/yakuake-3.0.5-r1.ebuild
new file mode 100644
index 000000000000..afa2667addc2
--- /dev/null
+++ b/kde-apps/yakuake/yakuake-3.0.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Quake-style terminal emulator based on konsole"
+HOMEPAGE="https://yakuake.kde.org/"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz
+ https://dev.gentoo.org/~asturm/distfiles/${P}-patches.tar.xz"
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-2 LGPL-2"
+IUSE="absolute-position X"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep konsole)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ absolute-position? ( $(add_frameworks_dep kwayland) )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ )
+"
+RDEPEND="${DEPEND}
+ !kde-misc/yakuake:4
+"
+
+PATCHES=( "${WORKDIR}/${P}-patches" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package absolute-position KF5Wayland)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}