summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-15 23:01:21 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-17 13:13:13 +0200
commit06e70a05e74d23fcbb57deb324b67dab0bebd587 (patch)
treef8cb144496d088c88ca9c8197e4a24f9faed1e60 /kde-apps
parentsys-block/partitionmanager: Raise minimum sys-libs/kpmcore (diff)
downloadgentoo-06e70a05e74d23fcbb57deb324b67dab0bebd587.tar.gz
gentoo-06e70a05e74d23fcbb57deb324b67dab0bebd587.tar.bz2
gentoo-06e70a05e74d23fcbb57deb324b67dab0bebd587.zip
kde-apps/cantor: Update python.patch with upstream review changes
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/cantor/cantor-20.08.2.ebuild5
-rw-r--r--kde-apps/cantor/files/cantor-20.08.3-python.patch (renamed from kde-apps/cantor/files/cantor-20.08.2-python.patch)19
2 files changed, 12 insertions, 12 deletions
diff --git a/kde-apps/cantor/cantor-20.08.2.ebuild b/kde-apps/cantor/cantor-20.08.2.ebuild
index 5ed83ea22785..9ac4987f1a13 100644
--- a/kde-apps/cantor/cantor-20.08.2.ebuild
+++ b/kde-apps/cantor/cantor-20.08.2.ebuild
@@ -13,8 +13,7 @@ QTMIN=5.14.2
inherit ecm kde.org optfeature python-single-r1
DESCRIPTION="Interface for doing mathematics and scientific computing"
-HOMEPAGE="https://kde.org/applications/education/org.kde.cantor
-https://edu.kde.org/cantor/"
+HOMEPAGE="https://kde.org/applications/en/cantor https://edu.kde.org/cantor/"
LICENSE="GPL-2" # TODO: CHECK
SLOT="5"
@@ -74,7 +73,7 @@ RDEPEND="${DEPEND}
RESTRICT+=" test"
-PATCHES=( "${FILESDIR}/${P}-python.patch" )
+PATCHES=( "${FILESDIR}/${PN}-20.08.3-python.patch" )
pkg_setup() {
use python && python-single-r1_pkg_setup
diff --git a/kde-apps/cantor/files/cantor-20.08.2-python.patch b/kde-apps/cantor/files/cantor-20.08.3-python.patch
index 0f3c67746284..c0dc3804c83c 100644
--- a/kde-apps/cantor/files/cantor-20.08.2-python.patch
+++ b/kde-apps/cantor/files/cantor-20.08.3-python.patch
@@ -1,13 +1,14 @@
-From c09628ae8c08e8ef0e57b801994acd4276b65b02 Mon Sep 17 00:00:00 2001
+From c794fb5f0f616ce2d9e4004fc459a1c50f077470 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Sun, 11 Oct 2020 22:47:55 +0200
Subject: [PATCH] Use CMake FindPython3 module, raises minimum CMake to 3.12
+Gives us out-of-the-box future proof python detection (python-3.9 right now).
---
CMakeLists.txt | 2 +-
src/backends/CMakeLists.txt | 10 ++++------
- src/backends/python/CMakeLists.txt | 4 ++--
- 3 files changed, 7 insertions(+), 9 deletions(-)
+ src/backends/python/CMakeLists.txt | 4 +---
+ 3 files changed, 6 insertions(+), 10 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e96e6df0..a90328b5 100644
@@ -44,24 +45,24 @@ index e99e1731..9b6b615e 100644
set_package_properties(LuaJIT PROPERTIES DESCRIPTION "A lightweight, extensible programming language (luajit implementation)."
URL "https://www.lua.org/"
diff --git a/src/backends/python/CMakeLists.txt b/src/backends/python/CMakeLists.txt
-index 04b4c313..ccf76193 100644
+index 04b4c313..c7868561 100644
--- a/src/backends/python/CMakeLists.txt
+++ b/src/backends/python/CMakeLists.txt
-@@ -14,7 +14,7 @@ set(PythonServer_SRCS
+@@ -14,8 +14,6 @@ set(PythonServer_SRCS
pythonserver.cpp
)
-include_directories(${PYTHONLIBS3_INCLUDE_DIRS})
-+include_directories(${Python3_INCLUDE_DIRS})
-
+-
qt5_add_resources(PythonBackend_RSCS python.qrc)
ki18n_wrap_ui(PythonBackend_SRCS settings.ui)
-@@ -34,7 +34,7 @@ set_target_properties(cantor_pythonserver PROPERTIES INSTALL_RPATH_USE_LINK_PATH
+ kconfig_add_kcfg_files(PythonBackend_SRCS settings.kcfgc)
+@@ -34,7 +32,7 @@ set_target_properties(cantor_pythonserver PROPERTIES INSTALL_RPATH_USE_LINK_PATH
if(MSVC)
set_property(TARGET cantor_pythonserver PROPERTY LINK_FLAGS "/SUBSYSTEM:CONSOLE")
endif()
-target_link_libraries(cantor_pythonserver ${PYTHONLIBS3_LIBRARIES})
-+target_link_libraries(cantor_pythonserver ${Python3_LIBRARIES})
++target_link_libraries(cantor_pythonserver Python3::Python)
if(BUILD_TESTING)
add_executable(testpython testpython.cpp settings.cpp)