summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-24 12:05:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-24 15:46:41 +0200
commit391046b8f76d6692a0a19b2d3ce16a39c2013614 (patch)
treeaccd3e74356ac5b4577ef69127e4119010edbb12 /kde-apps
parentkde-apps/kwalletmanager: 21.04.0 version bump (diff)
downloadgentoo-391046b8f76d6692a0a19b2d3ce16a39c2013614.tar.gz
gentoo-391046b8f76d6692a0a19b2d3ce16a39c2013614.tar.bz2
gentoo-391046b8f76d6692a0a19b2d3ce16a39c2013614.zip
kde-apps/print-manager: 21.04.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-21.04.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index e05ba74c2a1d..fd40f773dc89 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1 +1,2 @@
DIST print-manager-20.12.3.tar.xz 258640 BLAKE2B db91464792bcc41781a73b2ae34f6a5b2df74f525367dd7668e0ba5b9261edadd8860bb9a1db38fede2313c5e18597481574fc06bd752fe3b7a887079e7d6590 SHA512 21030ecd3951cd1889ff4eb5a4998fc12f148d481bb66b8b7808fbcc5f38b1129e41e7e6d51ddd0ed2207c255be4c483d8960e05b02aed3f7691df85a7d1ba86
+DIST print-manager-21.04.0.tar.xz 259104 BLAKE2B 32e2324dd776f29928da16bd0ef95b72dc05c219b1d8c1be9e89f61566f0fd909e741efc621e10236c79b123faa82500609fd29d7b9aef84193dbb19c0c30d77 SHA512 3d3567111c28905e08748e864fda87b93cec2d2c42aedb996966c6cb8299ba1df32f4fbec7e3056c88bee5193f27fd1c70964c2e423602853da17bde34ce8d9a
diff --git a/kde-apps/print-manager/print-manager-21.04.0.ebuild b/kde-apps/print-manager/print-manager-21.04.0.ebuild
new file mode 100644
index 000000000000..04986407dc84
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-21.04.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.80.0
+PLASMA_MINIMAL=5.16.5
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PLASMA_MINIMAL}:5
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst(){
+ ecm_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}