summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-03 11:21:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-03 14:22:40 +0200
commit80b73a018eab467ee5b07719f6dac29ef2fc5b13 (patch)
treeefe4e880ef5df8c2701697b92895fdb2bccc920b /kde-apps
parentkde-apps/kwalletmanager: 20.08.1 version bump (diff)
downloadgentoo-80b73a018eab467ee5b07719f6dac29ef2fc5b13.tar.gz
gentoo-80b73a018eab467ee5b07719f6dac29ef2fc5b13.tar.bz2
gentoo-80b73a018eab467ee5b07719f6dac29ef2fc5b13.zip
kde-apps/print-manager: 20.08.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-20.08.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index 2a2ab52a88f6..55537ba94188 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1,2 +1,3 @@
DIST print-manager-20.04.3.tar.xz 255532 BLAKE2B 463c29f283c40d5a6b428ee77d6df4a80ac289e245ea9f520e71fb9032b84147b20bfb8dbc28d07dbe815b8b0b7eb1aa09853aaeb4d4adc45855cd2ed28938c2 SHA512 430116f46f69a8019dc891b108778b22f640b2ce2a6f5c4fdbee1eb84cee5f54e83c47bcac9ad85fb1e34a1072499b36943c88a444bdffc0cfb0f3f43d7950c2
DIST print-manager-20.08.0.tar.xz 258472 BLAKE2B 0f1471df545889a057108c6a7cbd8092fb064d4f2a89d5be660a238a62f53a42332c8c0a1cbb2fc2a6234c92b0e3b19f5255133d2d147e4478f2550e5ae42a17 SHA512 5a62bb82d64b10c5d40a971098db997ee9cdd9c2f09aa17e197db54df0f14d2391baa91eff40e6aed7ca692b3a11d9ffbe76722b5bf5159558f4b5d8407d422d
+DIST print-manager-20.08.1.tar.xz 258552 BLAKE2B 4bedb7c08a2b5533f1fb0f09ce830ed79dc480c63fa4ab83eb7f0c7a7903918a264a5074f6d02d8976bd8f67fe36279c898a2edf17e2c9b63d6ef307b4aedd59 SHA512 160adb6bda95ef7104acdbceb258eb64ef93cc120b35011db4f0ce134879113d9fc27617f5e4d810ac2857f092870719c0450dd0a481d0bbede0df473338a040
diff --git a/kde-apps/print-manager/print-manager-20.08.1.ebuild b/kde-apps/print-manager/print-manager-20.08.1.ebuild
new file mode 100644
index 000000000000..e3df96d48792
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-20.08.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.72.0
+PLASMA_MINIMAL=5.16.5
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PLASMA_MINIMAL}:5
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst(){
+ ecm_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}