summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-01-14 16:05:14 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-01-14 16:05:14 +0100
commit883fa01165178a1b9a9d5a9b3c5957296f0b5c1a (patch)
tree2bd2aac034c940295f6e8698ebc5d5e52c028c26 /kde-apps
parentnet-dns/pdns-recursor: optionally depend on systemd (diff)
downloadgentoo-883fa01165178a1b9a9d5a9b3c5957296f0b5c1a.tar.gz
gentoo-883fa01165178a1b9a9d5a9b3c5957296f0b5c1a.tar.bz2
gentoo-883fa01165178a1b9a9d5a9b3c5957296f0b5c1a.zip
kde-apps/ark: Backport runtime crash fix, add lrz postinst info
Reported-by: Arfrever Also added subslot operator to libarchive RDEPEND. Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/ark/ark-16.12.1-r1.ebuild74
-rw-r--r--kde-apps/ark/files/ark-16.12.1-fix-crash.patch21
2 files changed, 95 insertions, 0 deletions
diff --git a/kde-apps/ark/ark-16.12.1-r1.ebuild b/kde-apps/ark/ark-16.12.1-r1.ebuild
new file mode 100644
index 000000000000..8fdad666ece8
--- /dev/null
+++ b/kde-apps/ark/ark-16.12.1-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zlib"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib?]
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-fix-crash.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zlib ZLIB)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version app-arch/unar ; then
+ elog "For handling rar archives, install app-arch/unar"
+ fi
+
+ if ! has_version app-arch/p7zip ; then
+ elog "For handling 7-Zip archives, install app-arch/p7zip"
+ fi
+
+ if ! has_version app-arch/lrzip ; then
+ elog "For handling lrz archives, install app-arch/lrzip"
+ fi
+}
diff --git a/kde-apps/ark/files/ark-16.12.1-fix-crash.patch b/kde-apps/ark/files/ark-16.12.1-fix-crash.patch
new file mode 100644
index 000000000000..b416783de684
--- /dev/null
+++ b/kde-apps/ark/files/ark-16.12.1-fix-crash.patch
@@ -0,0 +1,21 @@
+commit b5e59a044d392ede62af23076bbf0a154d00bf60
+Author: Elvis Angelaccio <elvis.angelaccio@kde.org>
+Date: Fri Jan 13 16:14:35 2017 +0100
+
+ Stop crashing when loading the konqueror's webengine part
+
+ QtWebEngine requires this attribute set before the QGuiApplication
+ instance is created.
+
+diff --git a/app/main.cpp b/app/main.cpp
+index d375d79..d3a60b1 100644
+--- a/app/main.cpp
++++ b/app/main.cpp
+@@ -42,6 +42,7 @@ using Kerfuffle::AddToArchive;
+
+ int main(int argc, char **argv)
+ {
++ QCoreApplication::setAttribute(Qt::AA_ShareOpenGLContexts); // Required for the webengine part.
+ QApplication application(argc, argv);
+
+ /**