summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-06 17:12:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-06 22:13:32 +0200
commite962c62ea9d93dd3e2f0850206d5894b66d45f0b (patch)
tree4e444b69206a3041fce133739e4780add6198007 /kde-apps
parentdev-libs/libxslt: drop Python (2.7 only) bindings (diff)
downloadgentoo-e962c62ea9d93dd3e2f0850206d5894b66d45f0b.tar.gz
gentoo-e962c62ea9d93dd3e2f0850206d5894b66d45f0b.tar.bz2
gentoo-e962c62ea9d93dd3e2f0850206d5894b66d45f0b.zip
kde-apps/kitinerary: Fix build against poppler-20.08
Closes: https://bugs.gentoo.org/735800 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/kitinerary/files/kitinerary-20.04.3-poppler-20.08.patch32
-rw-r--r--kde-apps/kitinerary/kitinerary-20.04.3.ebuild2
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-apps/kitinerary/files/kitinerary-20.04.3-poppler-20.08.patch b/kde-apps/kitinerary/files/kitinerary-20.04.3-poppler-20.08.patch
new file mode 100644
index 000000000000..768cf5dc5097
--- /dev/null
+++ b/kde-apps/kitinerary/files/kitinerary-20.04.3-poppler-20.08.patch
@@ -0,0 +1,32 @@
+From 7098c8be9a5e7fabf74543308bfaf11a2ebe5484 Mon Sep 17 00:00:00 2001
+From: Volker Krause <vkrause@kde.org>
+Date: Wed, 5 Aug 2020 17:18:13 +0200
+Subject: [PATCH] Fix build with latest Poppler
+
+That now has a leading 0 in its minor version number.
+---
+ CMakeLists.txt | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e4d40f2..37787d8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -71,10 +71,10 @@ if(TARGET Poppler::Core)
+ endif()
+ endif()
+ if (HAVE_POPPLER)
+- string(REPLACE "." ";" _poppler_version_components ${Poppler_VERSION})
+- list(GET _poppler_version_components 0 POPPLER_VERSION_MAJOR)
+- list(GET _poppler_version_components 1 POPPLER_VERSION_MINOR)
+- list(GET _poppler_version_components 2 POPPLER_VERSION_PATCH)
++ string(REGEX MATCH "([0-9]+)\.0*([0-9]+)\.0*([0-9]+)" _match ${Poppler_VERSION})
++ set(POPPLER_VERSION_MAJOR ${CMAKE_MATCH_1})
++ set(POPPLER_VERSION_MINOR ${CMAKE_MATCH_2})
++ set(POPPLER_VERSION_PATCH ${CMAKE_MATCH_3})
+ endif()
+
+ if (TARGET ZXing::ZXing OR TARGET ZXing::Core)
+--
+GitLab
+
diff --git a/kde-apps/kitinerary/kitinerary-20.04.3.ebuild b/kde-apps/kitinerary/kitinerary-20.04.3.ebuild
index c4ff13c37148..2026a8ac89f6 100644
--- a/kde-apps/kitinerary/kitinerary-20.04.3.ebuild
+++ b/kde-apps/kitinerary/kitinerary-20.04.3.ebuild
@@ -35,6 +35,8 @@ RDEPEND="${DEPEND}
!<kde-apps/kdepim-addons-18.07.80
"
+PATCHES=( "${FILESDIR}/${P}-poppler-20.08.patch" ) # bug 735800
+
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package barcode ZXing)