summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-07-21 21:57:51 +0200
committerMichael Palimaka <kensington@gentoo.org>2016-07-28 01:55:39 +1000
commitbac2b5875708523b5317bb1588d8edb437d92832 (patch)
tree43b9c4c94c2afdaeeca97f6e5c84a41af8004167 /kde-base
parentprofiles: Add kde-base/kdelibs[webkit] to package.use.force (diff)
downloadgentoo-bac2b5875708523b5317bb1588d8edb437d92832.tar.gz
gentoo-bac2b5875708523b5317bb1588d8edb437d92832.tar.bz2
gentoo-bac2b5875708523b5317bb1588d8edb437d92832.zip
kde-base/kdelibs: Patch to use WEBKIT_REQUIRED=optional
Add WEBKIT_REQUIRED="always" to <4.14.22 - these were not patched. Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdelibs/files/kdelibs-4.14.22-webkit.patch85
-rw-r--r--kde-base/kdelibs/kdelibs-4.14.20-r2.ebuild3
-rw-r--r--kde-base/kdelibs/kdelibs-4.14.21.ebuild3
-rw-r--r--kde-base/kdelibs/kdelibs-4.14.22.ebuild5
4 files changed, 93 insertions, 3 deletions
diff --git a/kde-base/kdelibs/files/kdelibs-4.14.22-webkit.patch b/kde-base/kdelibs/files/kdelibs-4.14.22-webkit.patch
new file mode 100644
index 000000000000..dcbb565cedc6
--- /dev/null
+++ b/kde-base/kdelibs/files/kdelibs-4.14.22-webkit.patch
@@ -0,0 +1,85 @@
+--- a/CMakeLists.txt 2016-07-06 12:18:35.000000000 +0200
++++ b/CMakeLists.txt 2016-07-21 21:40:26.080328514 +0200
+@@ -45,6 +45,9 @@
+ ############### Give the user the option to build the deprecated WMI solid backend instead of the new win backend ###############
+ option(WITH_SOLID_WMI "Enables the deprecated WMI backend on Windows")
+
++############### Give the user the option to build without qtwebkit dependency ###############
++option(WITH_KDEWEBKIT "Enables the deprecated kdewebkit and kdewebkit-widgets" "ON")
++
+ ############### Load the CTest options ###############
+ # CTestCustom.cmake has to be in the CTEST_BINARY_DIR.
+ # in the KDE build system, this is the same as CMAKE_BINARY_DIR.
+@@ -363,7 +366,9 @@
+ add_subdirectory( plasma )
+ endif(NOT WINCE)
+ add_subdirectory( kunitconversion )
++if(WITH_KDEWEBKIT)
+ add_subdirectory( kdewebkit )
++endif(WITH_KDEWEBKIT)
+ add_subdirectory( includes )
+
+ add_subdirectory( experimental )
+--- a/kdewidgets/CMakeLists.txt 2016-07-06 12:18:35.000000000 +0200
++++ b/kdewidgets/CMakeLists.txt 2016-07-21 21:39:54.031052674 +0200
+@@ -90,6 +90,7 @@
+
+
+ # kdewebkit widgets
++ if(WITH_KDEWEBKIT)
+ include_directories(
+ ${CMAKE_SOURCE_DIR}/kdewebkit
+ )
+@@ -121,7 +122,7 @@
+ endif(NOT WIN32)
+
+ install(TARGETS kdewebkitwidgets DESTINATION ${PLUGIN_INSTALL_DIR}/plugins/designer )
+-
++ endif(WITH_KDEWEBKIT)
+
+ if (QT_QT3SUPPORT_FOUND)
+
+--- a/plasma/CMakeLists.txt 2016-07-22 01:26:52.992198945 +0200
++++ b/plasma/CMakeLists.txt 2016-07-22 01:28:10.487904045 +0200
+@@ -10,6 +10,10 @@
+ set(PLASMA_NO_GLOBAL_SHORTCUTS TRUE)
+ endif(KDE_PLATFORM_FEATURE_BINARY_COMPATIBLE_FEATURE_REDUCTION)
+
++if(NOT WITH_KDEWEBKIT)
++ set(PLASMA_NO_KDEWEBKIT TRUE)
++endif(NOT WITH_KDEWEBKIT)
++
+ set(PLASMA_NO_PACKAGEKIT TRUE)
+
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}
+@@ -121,7 +125,6 @@
+ framesvg.cpp
+ plasma.cpp
+ popupapplet.cpp
+- private/animablegraphicswebview.cpp
+ private/applethandle.cpp
+ private/associatedapplicationmanager.cpp
+ private/componentinstaller.cpp
+@@ -211,7 +214,6 @@
+ widgets/textbrowser.cpp
+ widgets/treeview.cpp
+ widgets/textedit.cpp
+- widgets/webview.cpp
+
+ #Temporary QtJolie branch
+ private/qtjolie-branch/qtjolie/abstractadaptor.cpp
+@@ -245,6 +247,14 @@
+ )
+ endif(NOT KDE_NO_DEPRECATED)
+
++if(NOT PLASMA_NO_KDEWEBKIT)
++ set(plasma_LIB_SRCS
++ ${plasma_LIB_SRCS}
++ private/animablegraphicswebview.cpp
++ widgets/webview.cpp
++ )
++endif(NOT PLASMA_NO_KDEWEBKIT)
++
+ kde4_add_kcfg_files(plasma_LIB_SRCS data/kconfigxt/libplasma-theme-global.kcfgc)
+
+ kde4_add_ui_files(plasma_LIB_SRCS
diff --git a/kde-base/kdelibs/kdelibs-4.14.20-r2.ebuild b/kde-base/kdelibs/kdelibs-4.14.20-r2.ebuild
index 6692c977c139..3b2df45c0a40 100644
--- a/kde-base/kdelibs/kdelibs-4.14.20-r2.ebuild
+++ b/kde-base/kdelibs/kdelibs-4.14.20-r2.ebuild
@@ -7,8 +7,9 @@ EAPI=6
CMAKE_MIN_VERSION="3.3.1-r1"
CPPUNIT_REQUIRED="optional"
DECLARATIVE_REQUIRED="always"
-OPENGL_REQUIRED="optional"
KDE_HANDBOOK="optional"
+OPENGL_REQUIRED="optional"
+WEBKIT_REQUIRED="always"
inherit kde4-base fdo-mime multilib toolchain-funcs flag-o-matic
EGIT_BRANCH="KDE/4.14"
diff --git a/kde-base/kdelibs/kdelibs-4.14.21.ebuild b/kde-base/kdelibs/kdelibs-4.14.21.ebuild
index c3273ba80781..92f0b61f107d 100644
--- a/kde-base/kdelibs/kdelibs-4.14.21.ebuild
+++ b/kde-base/kdelibs/kdelibs-4.14.21.ebuild
@@ -7,8 +7,9 @@ EAPI=6
CMAKE_MIN_VERSION="3.3.1-r1"
CPPUNIT_REQUIRED="optional"
DECLARATIVE_REQUIRED="always"
-OPENGL_REQUIRED="optional"
KDE_HANDBOOK="optional"
+OPENGL_REQUIRED="optional"
+WEBKIT_REQUIRED="always"
inherit kde4-base fdo-mime multilib toolchain-funcs flag-o-matic
EGIT_BRANCH="KDE/4.14"
diff --git a/kde-base/kdelibs/kdelibs-4.14.22.ebuild b/kde-base/kdelibs/kdelibs-4.14.22.ebuild
index c47f63ced9bf..c2c1f1c828ac 100644
--- a/kde-base/kdelibs/kdelibs-4.14.22.ebuild
+++ b/kde-base/kdelibs/kdelibs-4.14.22.ebuild
@@ -7,8 +7,9 @@ EAPI=6
CMAKE_MIN_VERSION="3.3.1-r1"
CPPUNIT_REQUIRED="optional"
DECLARATIVE_REQUIRED="always"
-OPENGL_REQUIRED="optional"
KDE_HANDBOOK="optional"
+OPENGL_REQUIRED="optional"
+WEBKIT_REQUIRED="optional"
inherit kde4-base fdo-mime multilib toolchain-funcs flag-o-matic
APPS_VERSION="16.04.3" # Don't forget to bump this
@@ -133,6 +134,7 @@ PATCHES=(
"${FILESDIR}/${PN}-4.10.0-udisks.patch"
"${FILESDIR}/${PN}-4.14.20-FindQt4.patch"
"${FILESDIR}/${PN}-4.14.20-strigi-optional.patch"
+ "${FILESDIR}/${PN}-4.14.22-webkit.patch"
)
pkg_pretend() {
@@ -214,6 +216,7 @@ src_configure() {
-DWITH_UDev=$(usex udev)
-DWITH_SOLID_UDISKS2=$(usex udisks)
-DWITH_Avahi=$(usex zeroconf)
+ -DWITH_KDEWEBKIT=$(usex webkit)
)
kde4-base_src_configure