summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-06-12 20:49:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-12 20:49:22 +0200
commit40be27c1a70a5a91aed40b9ba72ffada8f181455 (patch)
tree8ebe11f07b05fabc128a918faf00bd0a2e2ab403 /kde-frameworks/frameworkintegration/frameworkintegration-5.35.0.ebuild
parentxfce-base/garcon: Add missing desc for gtk2 flag (diff)
downloadgentoo-40be27c1a70a5a91aed40b9ba72ffada8f181455.tar.gz
gentoo-40be27c1a70a5a91aed40b9ba72ffada8f181455.tar.bz2
gentoo-40be27c1a70a5a91aed40b9ba72ffada8f181455.zip
kde-frameworks: Add KDE Frameworks 5.35.0
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'kde-frameworks/frameworkintegration/frameworkintegration-5.35.0.ebuild')
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.35.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.35.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.35.0.ebuild
new file mode 100644
index 000000000000..736635e23d9f
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.35.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="appstream X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}