summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:27:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit64aa333e5583d97e0c79fbaab9e0d081306746c7 (patch)
treeafc45113905a61843b091a2cea9bc284100a34be /kde-frameworks/frameworkintegration
parentkde-apps/kpat: Add FRAMEWORKS_MINIMAL,QT_MINIMAL defs (diff)
downloadgentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.gz
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.bz2
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.zip
kde-frameworks: Add KDE Frameworks 5.50.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.50.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 83aab4849310..24496021408d 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.46.0.tar.xz 1753332 BLAKE2B 8ad4b5009096bcbf63a9b4874a353b84733aeadf577fc175ff17265aacda73ef4be543526ce6977756aba1758e56ebf65a3d66d98246ff3424a1540dcc906522 SHA512 34325df3f56d9e659237cb81bae755e2c4dd5b256d7878bcb3b1d3fdf15c749c5b8e2b590d27f93b6d5d31db73e826f63f988ac8c9544801ccd0591117653e12
DIST frameworkintegration-5.49.0.tar.xz 1753276 BLAKE2B f1294cd8ab228d8835eb975f59de544531fb50710145956d6610017e293d76c0282452cd3dd0c3e5fb34596ad67bcc1af53f723ec06fd8c9efafed3169122f08 SHA512 93105eb9bc93d85b5242ed5f8d48678c3c3a8d733448a05286534eb040099b29b6fb74cf34ce86d38ed89a982cfc7ede297e3dde90e6e6a80631e27ea952b2fe
+DIST frameworkintegration-5.50.0.tar.xz 1753332 BLAKE2B 86590e444da856729b572beeb092abe494c05420e813d6a131eb40861fdeb89719cebb1718a824e214022025bce767b01ecf2e53aa0de7dc355efb95ef8ff93a SHA512 e4efed63fc3fade085e68dd3dcef7c61d68a4fa2945ad4289c96acb1ce369a2fb763242a7d1ee205314560c5f6383018bceb0f7771da7fd2979cc375af22d61f
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.50.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.50.0.ebuild
new file mode 100644
index 000000000000..b6c0da034de8
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.50.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_QTHELP="false"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}