summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-14 22:17:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-14 22:33:29 +0100
commit78f2f4c1c946ea857f865805e7c8d77e9947986e (patch)
tree1aa176f5ffbdc956ad928aa22464cbc83da9fd78 /kde-frameworks/frameworkintegration
parentprofiles: Mask KDE Frameworks 5.91 (diff)
downloadgentoo-78f2f4c1c946ea857f865805e7c8d77e9947986e.tar.gz
gentoo-78f2f4c1c946ea857f865805e7c8d77e9947986e.tar.bz2
gentoo-78f2f4c1c946ea857f865805e7c8d77e9947986e.zip
kde-frameworks/frameworkintegration: 5.91.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.91.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index a0c3f00237b8..832b5044f3ed 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1 +1,2 @@
DIST frameworkintegration-5.90.0.tar.xz 1758208 BLAKE2B c8a7a11677ca77032be1ef1491ba5d8efa356caf6e7704b240a50baec7119b64ba85d4d183692164a1de58ee42c8d92686c9abe3d14af0bd8493ff747d9ddb7f SHA512 4f27d8aa453ab5d08e410db4c93bd86386159bb3e82a65cff0c4264ec3467f916a761e7cc0f68365c3f821cce8c84ff6277afb975a967fe26ed7a545155defca
+DIST frameworkintegration-5.91.0.tar.xz 1758260 BLAKE2B 06eaf929020ae55346b2f69f359c4840fb1c105305f0c7a34edbb70dfb5645e8842f50ef077dfb10100f233806d4c62d33b4fade606b294923b67ec2271cdba2 SHA512 6b82b77d7504e15c644e362b3f31c136e9c335c256f38eed9f079fb91d15d4a7bf1d25642359d9fcab02a39b8b4649271adcd5784ed579c19a7dcbd8bfc59899
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.91.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.91.0.ebuild
new file mode 100644
index 000000000000..035cdd529c64
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.91.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}