summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-12 10:24:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-12 15:35:00 +0100
commit9f729a3ed257b5878ea19a9bae536e90546dde9d (patch)
tree4cf6fbf0ff3bfc39b541d81b55fb2cfee0a64827 /kde-frameworks/frameworkintegration
parentdev-lang/mujs: stabilize v1.0.5 on amd64 (diff)
downloadgentoo-9f729a3ed257b5878ea19a9bae536e90546dde9d.tar.gz
gentoo-9f729a3ed257b5878ea19a9bae536e90546dde9d.tar.bz2
gentoo-9f729a3ed257b5878ea19a9bae536e90546dde9d.zip
kde-frameworks: Add KDE Frameworks 5.54.0
Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.54.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index bf8a96653ea9..4e7f707b3c4a 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.52.0.tar.xz 1753012 BLAKE2B a2f050d0243e2ac81bed9637fa58e10e1995db7f582a22e7c1d32f5339f26d4e85a12dde933867178e53b43a965d0702d4c8dc11ab18f8e15c541da381013461 SHA512 cc367f33c56d9fab467d3d5ba8119bb9ce36fdaa3133d4c3ef731dd1b9457497b459d48210cc78ee185e01097c7147829b9c3629c6d611dcc4b419f58e5f6194
DIST frameworkintegration-5.53.0.tar.xz 1753056 BLAKE2B a34bbded6d35f5bf4347704ca6344060db380e91781425f3daaf589c996d38d613606da4e69e81f1c11d81de1a113d643230c3ffaa892eb29ac897eac0fc7eb8 SHA512 054b851797a09d240abcc6c20f9beec33b331270e50e2760bdff9ec10b52657b76004985ec94b694459ebd729f94d67a2248dfd830c14383b9fa114583ad9d0f
+DIST frameworkintegration-5.54.0.tar.xz 1753080 BLAKE2B 267d6a7692d8d63ca19bf819955cb194c103eb996c0d144e4fa06f2bb5ca9c3a7b80084f4eb23ba94c69fc0004f5c7e5d7c6738b4108b7886903077e1312731f SHA512 9bb0c8a10b342976c21f8840e04f4b9ac60931c804fc0debbddf24b710e97804a2b8d357019840534c4fb4b4b816565a49682b0b09b4fb4d82d7d3467af1bb1f
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.54.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.54.0.ebuild
new file mode 100644
index 000000000000..1193df01fb71
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.54.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_QTHELP="false"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}