summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-14 09:52:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-14 10:46:34 +0200
commitdbadfce5e87c4c72a574f16f74da6869bc8bd913 (patch)
tree74397022d54ee3b66ecd07265ef27752c4355f92 /kde-frameworks/frameworkintegration
parentnet-misc/cni-plugins: Version bump to 0.8.0 (diff)
downloadgentoo-dbadfce5e87c4c72a574f16f74da6869bc8bd913.tar.gz
gentoo-dbadfce5e87c4c72a574f16f74da6869bc8bd913.tar.bz2
gentoo-dbadfce5e87c4c72a574f16f74da6869bc8bd913.zip
kde-frameworks: Add KDE Frameworks 5.58.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.58.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 8bbc49058c3b..eadd84320f49 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.54.0.tar.xz 1753080 BLAKE2B 267d6a7692d8d63ca19bf819955cb194c103eb996c0d144e4fa06f2bb5ca9c3a7b80084f4eb23ba94c69fc0004f5c7e5d7c6738b4108b7886903077e1312731f SHA512 9bb0c8a10b342976c21f8840e04f4b9ac60931c804fc0debbddf24b710e97804a2b8d357019840534c4fb4b4b816565a49682b0b09b4fb4d82d7d3467af1bb1f
DIST frameworkintegration-5.57.0.tar.xz 1753224 BLAKE2B 533532e20231e4d1d4bee8d5964c791a62f5d91a4e458b720e7d8086e92204b234846269f3ae6c23492bb77e0d42ae39da6d2dae85a1e034c0bd67be04639b88 SHA512 e8aadd2d4ead08ada18809b0a54879415dbf699885ec74c56dd689226a235fe6a034600a0b357162eee475c8798863ef0b50ea1384c603756b3dbfbf3425df1b
+DIST frameworkintegration-5.58.0.tar.xz 1754084 BLAKE2B ecafd5812b517188a95869ceb781c2be130297addbacbd426dcde2055cd402291f4899be0c39b418889ef58b944923816bed124a85fed6e3a10ef64a05596b83 SHA512 80f2d8c3dcaa57632bab12ca581ae57665b6bbea9f68aa439cf91f8bb7e987954a0b6787bc7f73e6e5cc8f605b28162a654bce6fa2aa3f699fc909fd5f0f5794
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.58.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.58.0.ebuild
new file mode 100644
index 000000000000..abb6426a7b47
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.58.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_QTHELP="false"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="appstream X"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+RDEPEND="${DEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}