summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-14 09:35:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-14 10:42:43 +0100
commita43ef7c319d1f064609c134655995c5aa40fdeea (patch)
treef183c922c6a7944d5dcd7588577d88ad73aa0367 /kde-frameworks/kbookmarks/kbookmarks-5.42.0.ebuild
parentsci-chemistry/avogadro: Fix cmake w/ >=GCC-6 (diff)
downloadgentoo-a43ef7c319d1f064609c134655995c5aa40fdeea.tar.gz
gentoo-a43ef7c319d1f064609c134655995c5aa40fdeea.tar.bz2
gentoo-a43ef7c319d1f064609c134655995c5aa40fdeea.zip
kde-frameworks: Add KDE Frameworks 5.42.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'kde-frameworks/kbookmarks/kbookmarks-5.42.0.ebuild')
-rw-r--r--kde-frameworks/kbookmarks/kbookmarks-5.42.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-frameworks/kbookmarks/kbookmarks-5.42.0.ebuild b/kde-frameworks/kbookmarks/kbookmarks-5.42.0.ebuild
new file mode 100644
index 000000000000..763576f16e6e
--- /dev/null
+++ b/kde-frameworks/kbookmarks/kbookmarks-5.42.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for managing bookmarks stored in XBEL format"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep kconfigwidgets)
+ nls? ( $(add_qt_dep linguist-tools) )
+"