summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-12 22:52:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-13 07:18:47 +0200
commit9b9e2943a43f23b7ad4818dfdd2ac43f11109c21 (patch)
tree75e2f7972b1f285202c309f03a11ce7cf597b86e /kde-frameworks/kcompletion/kcompletion-5.86.0.ebuild
parentkde-frameworks/kauth: 5.86.0 version bump (diff)
downloadgentoo-9b9e2943a43f23b7ad4818dfdd2ac43f11109c21.tar.gz
gentoo-9b9e2943a43f23b7ad4818dfdd2ac43f11109c21.tar.bz2
gentoo-9b9e2943a43f23b7ad4818dfdd2ac43f11109c21.zip
kde-frameworks/kcompletion: 5.86.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kcompletion/kcompletion-5.86.0.ebuild')
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.86.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/kcompletion-5.86.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.86.0.ebuild
new file mode 100644
index 000000000000..f0f1b4037efe
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.86.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ )
+ ecm_src_configure
+}