summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-09-09 13:29:10 +0200
committerJohannes Huber <johu@gentoo.org>2017-09-09 13:29:51 +0200
commit449b70581d8bd53212434c5c5b883099333502de (patch)
treecbfac5508f05db31d1c2b685f4e98d89c5a3ddde /kde-frameworks/kconfigwidgets/kconfigwidgets-5.38.0.ebuild
parentx11-misc/compton: Remove desktop-misc maintainership (reverts initial commit). (diff)
downloadgentoo-449b70581d8bd53212434c5c5b883099333502de.tar.gz
gentoo-449b70581d8bd53212434c5c5b883099333502de.tar.bz2
gentoo-449b70581d8bd53212434c5c5b883099333502de.zip
kde-frameworks: Version bump KDE Frameworks 5.38.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-frameworks/kconfigwidgets/kconfigwidgets-5.38.0.ebuild')
-rw-r--r--kde-frameworks/kconfigwidgets/kconfigwidgets-5.38.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-frameworks/kconfigwidgets/kconfigwidgets-5.38.0.ebuild b/kde-frameworks/kconfigwidgets/kconfigwidgets-5.38.0.ebuild
new file mode 100644
index 000000000000..a979d71e04be
--- /dev/null
+++ b/kde-frameworks/kconfigwidgets/kconfigwidgets-5.38.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing an assortment of configuration-related widgets"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+man"
+
+RDEPEND="
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}