summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:27:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit64aa333e5583d97e0c79fbaab9e0d081306746c7 (patch)
treeafc45113905a61843b091a2cea9bc284100a34be /kde-frameworks/kcrash/kcrash-5.50.0.ebuild
parentkde-apps/kpat: Add FRAMEWORKS_MINIMAL,QT_MINIMAL defs (diff)
downloadgentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.gz
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.bz2
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.zip
kde-frameworks: Add KDE Frameworks 5.50.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-frameworks/kcrash/kcrash-5.50.0.ebuild')
-rw-r--r--kde-frameworks/kcrash/kcrash-5.50.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/kcrash-5.50.0.ebuild b/kde-frameworks/kcrash/kcrash-5.50.0.ebuild
new file mode 100644
index 000000000000..627296fb3f0e
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.50.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ nls? ( $(add_qt_dep linguist-tools) )
+ test? ( $(add_qt_dep qtwidgets) )
+"