summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-10 20:23:19 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-10 20:44:12 +0200
commitb8c26e953cae54c7b1499590da63d2ed57387abf (patch)
tree674d2d52faf1af89ad1cea4a4c9b9309d092b001 /kde-frameworks/kcrash/kcrash-5.81.0.ebuild
parentkde-frameworks/kcontacts: 5.81.0 version bump (diff)
downloadgentoo-b8c26e953cae54c7b1499590da63d2ed57387abf.tar.gz
gentoo-b8c26e953cae54c7b1499590da63d2ed57387abf.tar.bz2
gentoo-b8c26e953cae54c7b1499590da63d2ed57387abf.zip
kde-frameworks/kcrash: 5.81.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kcrash/kcrash-5.81.0.ebuild')
-rw-r--r--kde-frameworks/kcrash/kcrash-5.81.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/kcrash-5.81.0.ebuild b/kde-frameworks/kcrash/kcrash-5.81.0.ebuild
new file mode 100644
index 000000000000..c9026f018d6a
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.81.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"