summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-05-31 21:39:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-31 22:21:28 +0200
commit5ee12cc942812f6368b3824a6aa2174a17eb338f (patch)
tree075a2d6470413022e3a02ed34ab4442b4637fcd2 /kde-frameworks/kdeclarative/kdeclarative-5.34.0-r1.ebuild
parentwww-client/chromium: dev channel bump (60.0.3112.7) (diff)
downloadgentoo-5ee12cc942812f6368b3824a6aa2174a17eb338f.tar.gz
gentoo-5ee12cc942812f6368b3824a6aa2174a17eb338f.tar.bz2
gentoo-5ee12cc942812f6368b3824a6aa2174a17eb338f.zip
kde-frameworks/kdeclarative: Fix plasmashell/taskman memleak
See also: https://bugs.kde.org/show_bug.cgi?id=380270 Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'kde-frameworks/kdeclarative/kdeclarative-5.34.0-r1.ebuild')
-rw-r--r--kde-frameworks/kdeclarative/kdeclarative-5.34.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kdeclarative/kdeclarative-5.34.0-r1.ebuild b/kde-frameworks/kdeclarative/kdeclarative-5.34.0-r1.ebuild
new file mode 100644
index 000000000000..da3138effd9e
--- /dev/null
+++ b/kde-frameworks/kdeclarative/kdeclarative-5.34.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Framework providing integration of QML and KDE work spaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# drop qtdeclarative subslot operator when QT_MINIMAL >= 5.8.0
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdeclarative '' '' '5=')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ media-libs/libepoxy
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-memleak.patch" )