summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 15:05:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 15:05:44 +0100
commitfc673f93b204709bd56426d01fb497d17a231549 (patch)
treea4e35f1a0c18dd58b04ced4408e79f76c9383ffc /kde-frameworks/kholidays
parentkde-apps/kalarm: Drop bogus COMMON_DEPEND (diff)
downloadgentoo-fc673f93b204709bd56426d01fb497d17a231549.tar.gz
gentoo-fc673f93b204709bd56426d01fb497d17a231549.tar.bz2
gentoo-fc673f93b204709bd56426d01fb497d17a231549.zip
kde-frameworks: Add KDE Frameworks 5.55.0
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kholidays')
-rw-r--r--kde-frameworks/kholidays/Manifest1
-rw-r--r--kde-frameworks/kholidays/kholidays-5.55.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/kholidays/Manifest b/kde-frameworks/kholidays/Manifest
index d260f06876f4..1d88a4646e3e 100644
--- a/kde-frameworks/kholidays/Manifest
+++ b/kde-frameworks/kholidays/Manifest
@@ -1 +1,2 @@
DIST kholidays-5.54.0.tar.xz 202208 BLAKE2B 4efd8f4168db8c265d0d0a9741227f3a70d6916e1734825037f6249f5bc2a98186dfb3864a6b096a63dad145eeb98bffb83c1502fd8ec3ff2b62a893143a721d SHA512 709b229c31cb59692d979d8dc36574997e05d674b2cd14913c620a968b243bbcd88f14e9f488f6aec6615102f713c1b4d34f6b817111396cdfedd470d358a675
+DIST kholidays-5.55.0.tar.xz 202256 BLAKE2B 993558a56d0ec1244c112204a5770552fb3a3ae0dc9eb2b70d1176ee8cdd707880d0df292c3dd2d983af285057cda3515032b548291510dee97ddcd469d6e89f SHA512 700ec6b69ba1f402e3bc4d478c49fae1567007eb6741b1f0c54d049c041fb7e830d28a736af44dd6bea36df10e7408345ee3e1abed89a537be834bfe059d7859
diff --git a/kde-frameworks/kholidays/kholidays-5.55.0.ebuild b/kde-frameworks/kholidays/kholidays-5.55.0.ebuild
new file mode 100644
index 000000000000..26d503ce0f04
--- /dev/null
+++ b/kde-frameworks/kholidays/kholidays-5.55.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_QTHELP="false"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Library to determine holidays and other special events for a geographical region"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_qt_dep qtdeclarative)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kholidays:5
+"
+
+src_test() {
+ # bug 624214
+ mkdir -p "${HOME}/.local/share/kf5/libkholidays" || die
+ cp -r "${S}/holidays/plan2" "${HOME}/.local/share/kf5/libkholidays/" || die
+ kde5_src_test
+}