summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 00:21:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 10:19:23 +0200
commit832934f31e45d450d2eaee2a9ebd501303303c43 (patch)
tree26ddfbcde55dc86490c71053a6813be8c3a8c212 /kde-frameworks/ki18n/ki18n-5.61.0.ebuild
parentmedia-gfx/digikam: Drop 6.1.0 (diff)
downloadgentoo-832934f31e45d450d2eaee2a9ebd501303303c43.tar.gz
gentoo-832934f31e45d450d2eaee2a9ebd501303303c43.tar.bz2
gentoo-832934f31e45d450d2eaee2a9ebd501303303c43.zip
kde-frameworks: Add KDE Frameworks 5.61.0
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/ki18n/ki18n-5.61.0.ebuild')
-rw-r--r--kde-frameworks/ki18n/ki18n-5.61.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-frameworks/ki18n/ki18n-5.61.0.ebuild b/kde-frameworks/ki18n/ki18n-5.61.0.ebuild
new file mode 100644
index 000000000000..e3e7919c8a54
--- /dev/null
+++ b/kde-frameworks/ki18n/ki18n-5.61.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit kde5 python-single-r1
+
+DESCRIPTION="Framework based on Gettext for internationalizing user interface text"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(add_qt_dep qtdeclarative)
+ sys-devel/gettext
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ test? ( $(add_qt_dep qtconcurrent) )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-5.57.0-python.patch" )
+
+pkg_setup() {
+ kde5_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ kde5_src_configure
+}