summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 01:41:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-09 14:09:29 +0200
commit76c3d92584e8de8181bc52d1c3e73045c61e72ba (patch)
tree06423ca7d9f0ad65c50faf17eef61c9cc192387b /kde-frameworks/ki18n/ki18n-5.82.0.ebuild
parentkde-frameworks/kholidays: 5.82.0 version bump (diff)
downloadgentoo-76c3d92584e8de8181bc52d1c3e73045c61e72ba.tar.gz
gentoo-76c3d92584e8de8181bc52d1c3e73045c61e72ba.tar.bz2
gentoo-76c3d92584e8de8181bc52d1c3e73045c61e72ba.zip
kde-frameworks/ki18n: 5.82.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/ki18n/ki18n-5.82.0.ebuild')
-rw-r--r--kde-frameworks/ki18n/ki18n-5.82.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-frameworks/ki18n/ki18n-5.82.0.ebuild b/kde-frameworks/ki18n/ki18n-5.82.0.ebuild
new file mode 100644
index 000000000000..c163b404f540
--- /dev/null
+++ b/kde-frameworks/ki18n/ki18n-5.82.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+QTMIN=5.15.2
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Framework based on Gettext for internationalizing user interface text"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ sys-devel/gettext
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtconcurrent-${QTMIN}:5 )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-5.57.0-python.patch" )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ ecm_src_configure
+}