summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-11-14 02:40:02 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-11-14 03:46:21 +1100
commit3590519f6327cd955ddc8cd28999a35d935b417a (patch)
tree6f49892057aa5fdc43b436e23b7b48f55017e61e /kde-frameworks/kinit/kinit-5.16.0.ebuild
parentprofiles: mask kde-frameworks/{knotifications,ktextwidgets}[speech] (diff)
downloadgentoo-3590519f6327cd955ddc8cd28999a35d935b417a.tar.gz
gentoo-3590519f6327cd955ddc8cd28999a35d935b417a.tar.bz2
gentoo-3590519f6327cd955ddc8cd28999a35d935b417a.zip
kde-frameworks: version bump 5.16.0
Package-Manager: portage-2.2.24
Diffstat (limited to 'kde-frameworks/kinit/kinit-5.16.0.ebuild')
-rw-r--r--kde-frameworks/kinit/kinit-5.16.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-frameworks/kinit/kinit-5.16.0.ebuild b/kde-frameworks/kinit/kinit-5.16.0.ebuild
new file mode 100644
index 000000000000..5f0a8909d2cb
--- /dev/null
+++ b/kde-frameworks/kinit/kinit-5.16.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Helper library to speed up start of applications on KDE work spaces"
+LICENSE="LGPL-2+"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="+caps +man"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwindowsystem)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ x11-libs/libX11
+ caps? ( sys-libs/libcap )
+"
+DEPEND="${RDEPEND}
+ man? ( $(add_frameworks_dep kdoctools) )
+ x11-proto/xproto
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package caps Libcap)
+ $(cmake-utils_use_find_package man KF5DocTools)
+ )
+
+ kde5_src_configure
+}