summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-16 17:15:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-16 17:20:50 +0200
commit798f6de5b40e392c7738342cab9f4b8eb75ebcf3 (patch)
tree4f23fc404baa866a97d22772156c3c81a0b3822c /kde-frameworks/kio
parentkde-apps/okular: Drop 21.04.3 (r0) (diff)
downloadgentoo-798f6de5b40e392c7738342cab9f4b8eb75ebcf3.tar.gz
gentoo-798f6de5b40e392c7738342cab9f4b8eb75ebcf3.tar.bz2
gentoo-798f6de5b40e392c7738342cab9f4b8eb75ebcf3.zip
kde-frameworks/kio: Fix selecting binaries from component chooser KCM
Upstream commit 8ad6921524c92a0cf1b58336b3ce29e159e83b7d See also: https://mail.kde.org/pipermail/distributions/2021-July/001035.html KDE-bug: https://bugs.kde.org/show_bug.cgi?id=439477 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kio')
-rw-r--r--kde-frameworks/kio/files/kio-5.84.0-fix-open-url-w-binary.patch53
-rw-r--r--kde-frameworks/kio/kio-5.84.0-r1.ebuild100
2 files changed, 153 insertions, 0 deletions
diff --git a/kde-frameworks/kio/files/kio-5.84.0-fix-open-url-w-binary.patch b/kde-frameworks/kio/files/kio-5.84.0-fix-open-url-w-binary.patch
new file mode 100644
index 000000000000..cdccada57d97
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.84.0-fix-open-url-w-binary.patch
@@ -0,0 +1,53 @@
+From 8ad6921524c92a0cf1b58336b3ce29e159e83b7d Mon Sep 17 00:00:00 2001
+From: David Edmundson <kde@davidedmundson.co.uk>
+Date: Wed, 14 Jul 2021 17:06:59 +0100
+Subject: [PATCH] Fix selecting binaries from component chooser KCM
+
+In the kcmshell for a component chooser we use the open with dialog to
+select services for various scheme handlers.
+
+If you select a binary instead of a .desktop file a temporary .desktop
+file is created in ~/.local/share/applications
+
+This is in the format
+Exec=someBinary
+MimeType=x-scheme-handler/http
+
+When we then use this application for launching KIO::DesktopExecParser
+then (sort of correctly) determines that that the chosen service cannot
+handle the http scheme because even though it is a scheme handler it
+does not have a "%u" in the exec line.
+
+This leads to us potentially loading websites via kioclient or kio-fuse.
+
+Testing done:
+ - kcmshell5 component chooser
+ - web browser -> other -> type "/usr/bin/firefox"
+ - kde-open5 http://kde.org
+ - Previously this gave a local URL, now it is correct
+---
+ src/widgets/kopenwithdialog.cpp | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/src/widgets/kopenwithdialog.cpp b/src/widgets/kopenwithdialog.cpp
+index 1831878ca..31295044d 100644
+--- a/src/widgets/kopenwithdialog.cpp
++++ b/src/widgets/kopenwithdialog.cpp
+@@ -1088,6 +1088,14 @@ bool KOpenWithDialogPrivate::checkAccept()
+ KConfigGroup cg = desktopFile.desktopGroup();
+ cg.writeEntry("Type", "Application");
+ cg.writeEntry("Name", initialServiceName);
++
++ // if we select a binary for a scheme handler, then it's safe to assume it can handle URLs
++ if (qMimeType.startsWith(QLatin1String("x-scheme-handler/"))) {
++ if (!typedExec.contains(QLatin1String("%u"), Qt::CaseInsensitive) && !typedExec.contains(QLatin1String("%f"), Qt::CaseInsensitive)) {
++ fullExec += QStringLiteral(" %u");
++ }
++ }
++
+ cg.writeEntry("Exec", fullExec);
+ cg.writeEntry("NoDisplay", true); // don't make it appear in the K menu
+ if (terminal->isChecked()) {
+--
+GitLab
+
diff --git a/kde-frameworks/kio/kio-5.84.0-r1.ebuild b/kde-frameworks/kio/kio-5.84.0-r1.ebuild
new file mode 100644
index 000000000000..e4d40e939fa3
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.84.0-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org xdg-utils
+
+DESCRIPTION="Framework providing transparent file and data management"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl +handbook kerberos +kwallet X"
+
+# tests hang
+RESTRICT+=" test"
+
+RDEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/kauth-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kbookmarks-${PVCUT}*:5
+ =kde-frameworks/kcodecs-${PVCUT}*:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kcrash-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kjobwidgets-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/ktextwidgets-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ =kde-frameworks/solid-${PVCUT}*:5
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ handbook? ( =kde-frameworks/kdoctools-${PVCUT}*:5 )
+ kerberos? ( virtual/krb5 )
+ kwallet? ( =kde-frameworks/kwallet-${PVCUT}*:5 )
+ X? ( >=dev-qt/qtx11extras-${QTMIN}:5 )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ test? ( sys-libs/zlib )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libX11
+ x11-libs/libXrender
+ )
+"
+PDEPEND=">=kde-frameworks/kded-${PVCUT}:5"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-qtconcurrent-private-link.patch # bug 784971
+ "${FILESDIR}"/${P}-cxx17-std-mem_fn.patch # bug 802030
+ "${FILESDIR}"/${P}-fix-open-url-w-binary.patch # KDE-bug 439477
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DKIO_NO_PUBLIC_QTCONCURRENT=ON
+ $(cmake_use_find_package acl ACL)
+ $(cmake_use_find_package handbook KF5DocTools)
+ $(cmake_use_find_package kerberos GSSAPI)
+ $(cmake_use_find_package kwallet KF5Wallet)
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ ecm_pkg_postrm
+ xdg_desktop_database_update
+}