summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-14 14:36:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-14 14:36:48 +0200
commitef5ff74686160669fea3f413f70e13f6493e8ca7 (patch)
treed2e17fe58a654c23f0102149dd0ffc92e7e8779d /kde-frameworks/kio
parentkde-apps/kturtle: Remove po/sq/docs from 21.04.3 (diff)
downloadgentoo-ef5ff74686160669fea3f413f70e13f6493e8ca7.tar.gz
gentoo-ef5ff74686160669fea3f413f70e13f6493e8ca7.tar.bz2
gentoo-ef5ff74686160669fea3f413f70e13f6493e8ca7.zip
kde-frameworks/kio: Fix build with clang[default-libcxx]
Upstream commit 36f1814b184f4d5ac628fca5db5f6cc1440b4db7 See also: https://mail.kde.org/pipermail/distributions/2021-July/001033.html KDE-bug: https://bugs.kde.org/show_bug.cgi?id=439780 Reported-by: 12101111 <w12101111@outlook.com> Closes: https://bugs.gentoo.org/802030 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kio')
-rw-r--r--kde-frameworks/kio/files/kio-5.84.0-cxx17-std-mem_fn.patch31
-rw-r--r--kde-frameworks/kio/kio-5.84.0.ebuild4
2 files changed, 33 insertions, 2 deletions
diff --git a/kde-frameworks/kio/files/kio-5.84.0-cxx17-std-mem_fn.patch b/kde-frameworks/kio/files/kio-5.84.0-cxx17-std-mem_fn.patch
new file mode 100644
index 000000000000..26383b788a01
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.84.0-cxx17-std-mem_fn.patch
@@ -0,0 +1,31 @@
+From 36f1814b184f4d5ac628fca5db5f6cc1440b4db7 Mon Sep 17 00:00:00 2001
+From: Jan Paul Batrina <jpmbatrina01@gmail.com>
+Date: Mon, 12 Jul 2021 22:06:19 +0800
+Subject: [PATCH] Use std::mem_fn instead of the deprecated/removed
+ std::mem_fun
+
+std::mem_fun was deprecated in C++11 and removed from
+the standard in C++17.
+
+BUG: 439780
+NO_CHANGELOG
+---
+ src/widgets/kpropertiesdialog.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/widgets/kpropertiesdialog.cpp b/src/widgets/kpropertiesdialog.cpp
+index 3f61e8ea3..1ed8bc7d8 100644
+--- a/src/widgets/kpropertiesdialog.cpp
++++ b/src/widgets/kpropertiesdialog.cpp
+@@ -2273,7 +2273,7 @@ void KFilePermissionsPropsPlugin::slotShowAdvancedPermissions()
+ d->fileSystemSupportsACLs = fileSystemSupportsACL(path);
+ }
+ if (d->fileSystemSupportsACLs) {
+- std::for_each(theNotSpecials.begin(), theNotSpecials.end(), std::mem_fun(&QWidget::hide));
++ std::for_each(theNotSpecials.begin(), theNotSpecials.end(), std::mem_fn(&QWidget::hide));
+ extendedACLs = new KACLEditWidget(&dlg);
+ extendedACLs->setEnabled(d->canChangePermissions);
+ vbox->addWidget(extendedACLs);
+--
+GitLab
+
diff --git a/kde-frameworks/kio/kio-5.84.0.ebuild b/kde-frameworks/kio/kio-5.84.0.ebuild
index cc327525d7b5..ee9c97e0d68e 100644
--- a/kde-frameworks/kio/kio-5.84.0.ebuild
+++ b/kde-frameworks/kio/kio-5.84.0.ebuild
@@ -71,8 +71,8 @@ DEPEND="${RDEPEND}
PDEPEND=">=kde-frameworks/kded-${PVCUT}:5"
PATCHES=(
- # pending https://invent.kde.org/frameworks/kio/-/merge_requests/426
- "${FILESDIR}"/${PN}-5.84.0-fix-qtconcurrent-private-link.patch # bug 784971
+ "${FILESDIR}"/${P}-fix-qtconcurrent-private-link.patch # bug 784971
+ "${FILESDIR}"/${P}-cxx17-std-mem_fn.patch # bug 802030
)
src_configure() {