summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-10 14:15:21 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-10 14:29:24 +0100
commitb58a4eed24e3ca606144d7c6c9befd4840e71b99 (patch)
treef0f20a5d61644cf34953b44d420c5bc748766d35 /kde-frameworks/knotifications/knotifications-5.52.0.ebuild
parentsys-cluster/slurm: Fix init stuff (diff)
downloadgentoo-b58a4eed24e3ca606144d7c6c9befd4840e71b99.tar.gz
gentoo-b58a4eed24e3ca606144d7c6c9befd4840e71b99.tar.bz2
gentoo-b58a4eed24e3ca606144d7c6c9befd4840e71b99.zip
kde-frameworks: Add KDE Frameworks 5.52.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-frameworks/knotifications/knotifications-5.52.0.ebuild')
-rw-r--r--kde-frameworks/knotifications/knotifications-5.52.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-frameworks/knotifications/knotifications-5.52.0.ebuild b/kde-frameworks/knotifications/knotifications-5.52.0.ebuild
new file mode 100644
index 000000000000..9489c42823fc
--- /dev/null
+++ b/kde-frameworks/knotifications/knotifications-5.52.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Framework for notifying the user of an event"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="dbus nls phonon speech X"
+
+RDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dbus? ( dev-libs/libdbusmenu-qt[qt5(+)] )
+ !phonon? ( media-libs/libcanberra )
+ phonon? ( media-libs/phonon[qt5(+)] )
+ speech? ( $(add_qt_dep qtspeech) )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+ X? ( x11-base/xorg-proto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package dbus dbusmenu-qt5)
+ $(cmake-utils_use_find_package !phonon Canberra)
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}